General Discussionpermalink

MP4 player (Philips Ariaz) won't play programmes because of no DRM licence available

This discussion has been closed.

  • Message 81. Posted by Phil (U13764321) on Thursday, 24th February 2011 permalink

    I've never got it to work on MSC, I use MTP and it works fine for me.

    To do a system restore go to Start> Control panel>System Sercurity>Action Center> System Restore

    Follow the instructions and you should be ok. These instructions are for W7, You you're using XP it will differ slightly.

    complain

    This is a reply to this message.

  • Message 82. Posted by watervole (U14490581) on Thursday, 24th February 2011 permalink

    Hi Phil

    What is a system restore and why would I need to do a system restore?

    Thanks

    complain

    This is a reply to this message.

  • Message 83. Posted by Phil (U13764321) on Thursday, 24th February 2011 permalink

    A system restore takes Windows back to a time where the computer was stable and before the offending update was installed allowing you to transfer programmes and play on your Ariaz.

    It may work, it may not, but it's worth a try.

    complain

    This is a reply to this message.

  • Message 84. Posted by Jon Billings - BBC (U14029331) on Sunday, 27th February 2011 permalink

    System restore is an option when the video won't play on the PC or perhaps won't transfer correctly - however Watervole's problem sounds like a different issue.

    I think it can't ever have worked in MSC mode (although it could appear to, if you re-transferred a video that had previously been transferred by MTP - since the DRM license is kept on the device, even if you delete the video).

    What you describe (playing for a few minutes, then freezing) is post-DRM (i.e. the device has found the license and is decrypting), and is a problem decoding the video on the device.

    If it worked correctly previously then either things on the device have changed to cause this, OR its our video encoding profile.
    I'm pretty sure our video profile hasn't changed in the last couple of weeks, and I think there'd be more reports of this problem if it had.
    So, I'm thinking its the device, and performance related. This could be something like fragmentation of the drive (meaning the video is stored in many little chunks all over the devices drive, and it has to do more work when playing back to find and retrieve then chunks in order when playing back) OR there could be user selectable options on the device that increase theCPU load.

    Probably the easiest way to get both of those back to the original state would be to do a factory reset - which will wipe the disk and return it to as new state. (how to do this is described in the Philips documentation).

    If you do decide to give this a go, then of course remember to back up anything on the device you want to keep.
    I should also warn you that a factory reset will also completely reset the DRM, which means that the device will be treated as a new device by iPlayer and other DRM services. This isn't a problem for iPlayer , but let me know if you DO have DRM protected content from other sources, and I can try to explain what the issues would be.

    Jon

    This is a reply to this message.

  • Message 85. Posted by cometcycle (U14555524) on Monday, 28th February 2011 permalink

    Having exactly the same problems as in January. Unable to transfer to device in MTP mode and DRM expired message on device if MSC used.
    This is even happening on A History of Ancient Britain which worked for me last Thursday (24/2)

    complain

    This is a reply to this message.

  • Message 86. Posted by watervole (U14490581) on Tuesday, 1st March 2011 permalink

    Ok so I am again very confused! I was transferring and successfully watching programmes using the MSC mode for quite a few weeks and watching entire programmes on my MP4 player without having watched them first on my computer or having transferred them via the MTP mode. I have never been able to watch a programme using MTP mode because it freezes every few minutes - it has never not frozen as far am I am aware.

    As I'm not v techy I'll need to spend some time reading and doing the factory reset probably tomorrow now. But as soon as I have done it I will try downloading a few programmes and watching them and I'll update you on here.

    I dont really have anything else on my player other than music from my cds which I have on my laptop so dont think the licence thing will be a problem.

    I'll update you tomorrow. thanks for your reply and trying to help

    complain

    This is a reply to this message.

  • Message 87. Posted by Phil (U13764321) on Tuesday, 1st March 2011 permalink

    Which browser are using?

    complain

    This is a reply to this message.

  • Message 88. Posted by Phil (U13764321) on Tuesday, 1st March 2011 permalink

    What browser are you using?

    complain

    This is a reply to this message.

  • Message 89. Posted by watervole (U14490581) on Wednesday, 2nd March 2011 permalink

    Internet Explorer. Dont know what version and not sure how to look up what version I'm using. Havent done the reset yet as just got home form work.

    complain

    This is a reply to this message.

  • Message 90. Posted by Phil (U13764321) on Wednesday, 2nd March 2011 permalink

    If you go into internet explorer, if your menu bar is displayed. . On the menu bar there's a help bar on the menu, click on it and select about that will tell you what version of Internet Explorer you are running.

    complain

    This is a reply to this message.

  • Message 91. Posted by watervole (U14490581) on Thursday, 3rd March 2011 permalink

    I have Internet Explorer version 8

    complain

    This is a reply to this message.

  • Message 92. Posted by watervole (U14490581) on Thursday, 3rd March 2011 permalink

    Yeah! yeah! yeah! its working!

    Managed to watch Lead Balloon and Eastenders without any freezing using MTP. Hopefully thats the end of my MP3 player problems! I downloaded the Philips Software and updated the MP3 player and it works!

    Yeah!

    complain

    This is a reply to this message.

  • Message 93. Posted by Jon Billings - BBC (U14029331) on Monday, 7th March 2011 permalink

    This is a reply to this message.

  • Message 94. Posted by Jon Billings - BBC (U14029331) on Monday, 7th March 2011 permalink

    I'm really glad to hear it's working now.
    what made it work in the end?

    This is a reply to this message.

  • Message 95. Posted by watervole (U14490581) on Monday, 7th March 2011 permalink

    I reset the MP4 player by using the rest button on it. I then updated the software by going to the Philips website and downloaded their songbird software which included updates. One of these or combination worked! Strange though that it worked for about 3 weeks fine after you did the recoding and then it didnt work for 3 weeks and the reset and update seemed to get it working again. Strange.

    Thanks for helping me sort if out

    complain

    This is a reply to this message.

  • Message 96. Posted by Ursula Vasey (U13790935) on Monday, 7th March 2011 permalink

    It could be that the update you ran on the media player helped to download the relevant settings to allow the media player to read the Iplayer files correctly, including updating the version of the DRM so that they work in sync with each other.

    Whatever combination did it, it works, and that's what matters. Glad you are all sorted out Watervole.

    complain

    This is a reply to this message.

  • Message 97. Posted by watervole (U14490581) on Wednesday, 9th March 2011 permalink

    Thanks for all your advice everyone. For those of us with average techy skills these boards are great because there are people out there who know more and are able to help. I could never have sorted it out myself so thanks.

    Watervole :-}

    complain

    This is a reply to this message.

  • Message 98. Posted by matt (U8621220) on Wednesday, 9th March 2011 permalink

    Hi watervole,
    Sometime later this year the BBC will be closing these boards.

    Hopefully the community will continue though www.bbc.co.uk/dna/mb...

    complain

    This is a reply to this message.

  • Message 99. Posted by watervole (U14490581) on Thursday, 10th March 2011 permalink

    Thanks for that - I'll bookmark it ready to go. It's great to have support from others.

    complain

    This is a reply to this message.

BBC © 2014 The BBC is not responsible for the content of external sites. Read more.

This page is best viewed in an up-to-date web browser with style sheets (CSS) enabled. While you will be able to view the content of this page in your current browser, you will not be able to get the full visual experience. Please consider upgrading your browser software or enabling style sheets (CSS) if you are able to do so.