
    

<!DOCTYPE html>
<html lang="cy" id="responsive-news">
<head  prefix="og: http://ogp.me/ns#">
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <title>Galw am broses dendro wedi penderfyniad morlyn Abertawe - BBC Cymru Fyw</title>
    <meta name="description" content="Cwmnïau ynni llanw'n parhau i ddatblygu prosiectau er i Lywodraeth y DU wrthod cynllun morlyn Abertawe cwmni TLP.">
    <link rel="preload" as="style" href="http://static.bbci.co.uk/news/1.247.02790/stylesheets/services/cymrufyw/compact.css" media="(max-width: 599px)">
    <link rel="preload" as="style" href="http://static.bbci.co.uk/news/1.247.02790/stylesheets/services/cymrufyw/tablet.css" media="(min-width: 600px) and (max-width: 1007px)">
    <link rel="preload" as="style" href="http://static.bbci.co.uk/news/1.247.02790/stylesheets/services/cymrufyw/wide.css" media="(min-width: 1008px)">



    <link rel="dns-prefetch" href="//ssl.bbc.co.uk/">
    <link rel="dns-prefetch" href="//sa.bbc.co.uk/">
    <link rel="dns-prefetch" href="//ichef.bbci.co.uk/">



    <meta name="x-country" content="us">
    <meta name="x-audience" content="US">
    <meta name="CPS_AUDIENCE" content="US">
    <meta name="CPS_CHANGEQUEUEID" content="123464695">
    <link rel="canonical" href="http://www.bbc.co.uk/cymrufyw/44647890">
    <link rel="amphtml" href="https://www.bbc.co.uk/cymrufyw/amp/44647890">

                <meta property="og:title" content="'Cadw golwg' wedi penderfyniad morlyn" />
    <meta property="og:type" content="article" />
    <meta property="og:description" content="Cwmnïau ynni llanw'n parhau i ddatblygu prosiectau er i Lywodraeth y DU wrthod cynllun morlyn Abertawe cwmni TLP." />
    <meta property="og:site_name" content="BBC Cymru Fyw" />
    <meta property="og:locale" content="cy_GB" />
    <meta property="article:author" content="https://www.facebook.com/bbcnews" />
    <meta property="article:section" content="De-Orllewin" />
    <meta property="og:url" content="http://www.bbc.com/cymrufyw/44647890" />
    <meta property="og:image" content="https://ichef.bbci.co.uk/news/1024/cpsprodpb/13443/production/_93551987_hi037230351.jpg" />
    <meta property="og:image:alt" content="BBC Cymru Fyw. Tidal lagoon" />
    <meta property="fb:pages" content="215504865453262,362383043815651" />

    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@BBCCymruFyw">
    <meta name="twitter:title" content="'Cadw golwg' wedi penderfyniad morlyn">
    <meta name="twitter:description" content="Cwmnïau ynni llanw'n parhau i ddatblygu prosiectau er i Lywodraeth y DU wrthod cynllun morlyn Abertawe cwmni TLP.">
    <meta name="twitter:creator" content="@BBCCymruFyw">
    <meta name="twitter:image:src" content="https://ichef.bbci.co.uk/news/1024/cpsprodpb/13443/production/_93551987_hi037230351.jpg">
    <meta name="twitter:image:alt" content="Tidal lagoon" />
    <meta name="twitter:domain" content="www.bbc.co.uk">

    <script type="application/ld+json">
    {"@context":"http:\/\/schema.org","@type":"ReportageNewsArticle","url":"http:\/\/www.bbc.co.uk\/cymrufyw\/44647890","publisher":{"@type":"NewsMediaOrganization","name":"BBC Cymru Fyw","publishingPrinciples":"http:\/\/www.bbc.co.uk\/news\/help-41670342","logo":{"@type":"ImageObject","url":"https:\/\/www.bbc.co.uk\/news\/special\/2015\/newsspec_11063\/cymru_fyw_1024x576.png"}},"datePublished":"2018-06-29T09:15:59+01:00","dateModified":"2018-06-29T09:15:59+01:00","headline":"'Cadw golwg' wedi penderfyniad morlyn","image":{"@type":"ImageObject","width":720,"height":405,"url":"https:\/\/ichef.bbci.co.uk\/news\/720\/cpsprodpb\/13443\/production\/_93551987_hi037230351.jpg"},"thumbnailUrl":"https:\/\/ichef.bbci.co.uk\/news\/208\/cpsprodpb\/13443\/production\/_93551987_hi037230351.jpg","author":{"@type":"NewsMediaOrganization","name":"BBC Cymru Fyw","logo":{"@type":"ImageObject","url":"https:\/\/www.bbc.co.uk\/news\/special\/2015\/newsspec_11063\/cymru_fyw_1024x576.png"},"noBylinesPolicy":"http:\/\/www.bbc.co.uk\/news\/help-41670342#authorexpertise"},"mainEntityOfPage":"http:\/\/www.bbc.co.uk\/cymrufyw\/44647890"}
    </script>


                    <meta name="apple-itunes-app" content="app-id=900010506, app-argument=http://www.bbc.co.uk/cymrufyw/44647890?utm_medium=banner&utm_content=apple-itunes-app">
    
    <meta name="apple-mobile-web-app-title" content="BBC News">

<link rel="apple-touch-icon-precomposed" sizes="57x57"    href="http://static.bbci.co.uk/news/1.247.02790/apple-touch-icon-57x57-precomposed.png">
<link rel="apple-touch-icon-precomposed" sizes="72x72"    href="http://static.bbci.co.uk/news/1.247.02790/apple-touch-icon-72x72-precomposed.png">
<link rel="apple-touch-icon-precomposed" sizes="114x114"  href="http://static.bbci.co.uk/news/1.247.02790/apple-touch-icon-114x114-precomposed.png">
<link rel="apple-touch-icon-precomposed" sizes="144x144"  href="http://static.bbci.co.uk/news/1.247.02790/apple-touch-icon.png">
<link rel="apple-touch-icon" href="http://static.bbci.co.uk/news/1.247.02790/apple-touch-icon.png">
<link rel="apple-touch-startup-image" href="http://static.bbci.co.uk/news/1.247.02790/web-app-launch-icon.png">

<meta name="application-name" content="BBC News">
<meta name="msapplication-TileImage" content="BBC News">
<meta name="msapplication-TileColor" content="#bb1919">
<meta name="mobile-web-app-capable" content="yes">
    <meta http-equiv="cleartype" content="on">
    <meta name="robots" content="NOODP,NOYDIR" />
        <script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

    <script>
        (function() {
            if (navigator.userAgent.match(/IEMobile\/10\.0/)) {
                var msViewportStyle = document.createElement("style");
                msViewportStyle.appendChild(
                    document.createTextNode("@-ms-viewport{width:auto!important}")
                );
                document.getElementsByTagName("head")[0].appendChild(msViewportStyle);
            }
        })();
    </script>
    
    <script>window.fig = window.fig || {}; window.fig.async = true;</script>

    <meta property="fb:app_id" content="1609039196070050" />

           <meta name="viewport" content="width=device-width, initial-scale=1.0" />  <meta property="fb:admins" content="100004154058350" />  <script type="text/javascript">window.bbcredirection={geo:true}</script>  
<!--[if (gt IE 8) | (IEMobile)]><!-->
<link rel="stylesheet" href="http://static.bbci.co.uk/frameworks/barlesque/3.22.55/orb/4/style/orb.min.css">
<!--<![endif]-->

<!--[if (lt IE 9) & (!IEMobile)]>
<link rel="stylesheet" href="http://static.bbci.co.uk/frameworks/barlesque/3.22.55/orb/4/style/orb-ie.min.css">
<![endif]-->

  <!--orb.ws.require.lib--> <script class="js-require-lib" src="http://static.bbci.co.uk/frameworks/requirejs/lib.js"></script> <script type="text/javascript">  bbcRequireMap = {"jquery-1":"http://static.bbci.co.uk/frameworks/jquery/0.4.1/sharedmodules/jquery-1.7.2", "jquery-1.4":"http://static.bbci.co.uk/frameworks/jquery/0.4.1/sharedmodules/jquery-1.4", "jquery-1.9":"http://static.bbci.co.uk/frameworks/jquery/0.4.1/sharedmodules/jquery-1.9.1", "jquery-1.12":"http://static.bbci.co.uk/frameworks/jquery/0.4.1/sharedmodules/jquery-1.12.0.min", "jquery-2.2":"http://static.bbci.co.uk/frameworks/jquery/0.4.1/sharedmodules/jquery-2.2.0.min", "istats-1":"//nav.files.bbci.co.uk/nav-analytics/0.1.0-43/js/istats-1", "swfobject-2":"http://static.bbci.co.uk/frameworks/swfobject/0.1.10/sharedmodules/swfobject-2", "demi-1":"http://static.bbci.co.uk/frameworks/demi/0.10.1/sharedmodules/demi-1", "gelui-1":"http://static.bbci.co.uk/frameworks/gelui/0.9.13/sharedmodules/gelui-1", "cssp!gelui-1/overlay":"http://static.bbci.co.uk/frameworks/gelui/0.9.13/sharedmodules/gelui-1/overlay.css", "relay-1":"http://static.bbci.co.uk/frameworks/relay/0.2.6/sharedmodules/relay-1", "clock-1":"http://static.bbci.co.uk/frameworks/clock/0.1.9/sharedmodules/clock-1", "canvas-clock-1":"http://static.bbci.co.uk/frameworks/clock/0.1.9/sharedmodules/canvas-clock-1", "cssp!clock-1":"http://static.bbci.co.uk/frameworks/clock/0.1.9/sharedmodules/clock-1.css", "jssignals-1":"http://static.bbci.co.uk/frameworks/jssignals/0.3.6/modules/jssignals-1", "jcarousel-1":"http://static.bbci.co.uk/frameworks/jcarousel/0.1.10/modules/jcarousel-1", "bump-3":"//emp.bbci.co.uk/emp/bump-3/bump-3"}; require({ baseUrl: 'http://static.bbci.co.uk/', paths: bbcRequireMap, waitSeconds: 30 }); </script>   <script type="text/javascript">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</script> <script type="text/javascript">/*<![CDATA[*/
(function(){window.orb={};window.orb.figState={ad:0,ap:0,ck:1,eu:1,mb:0,tb:0,uk:1,df:1};window.orb.fig=function(a){return(arguments.length)?window.orb.figState[a]:window.orb.figState};window.orb.fig.device={};window.orb.fig.geo={};window.orb.fig.user={};window.orb.fig.isDefault=function(){return window.orb.fig("df")};window.orb.fig.device.isTablet=function(){return window.orb.fig("tb")};window.orb.fig.device.isMobile=function(){return window.orb.fig("mb")};window.orb.fig.geo.isUK=function(){return window.orb.fig("uk")};window.orb.fig.geo.isEU=function(){return window.orb.fig("eu")};window.fig=window.fig||{};window.fig.manager={include:function(e){e=e||window;var g=false;var j=e.document,k=j.cookie,i=k.match(/(?:^|; ?)ckns_orb_fig=([^;]+)/),h;if(i){i=this.deserialise(decodeURIComponent(RegExp.$1));this.setFig(e,i)}if(window.fig.async&&typeof JSON!="undefined"){var b=(document.cookie.match("(^|; )ckns_orb_cachedfig=([^;]*)")||0)[2];h=b?JSON.parse(b):null;if(h){this.setFig(e,h);g=true}}var a="https://fig.bbc.co.uk/frameworks/fig/1/fig.js";if(g){j.write('<script src="'+a+'" async><'+"/script>")}else{j.write('<script src="'+a+'"><'+"/script>")}},confirm:function(a){return true},setFig:function(a,b){(function(){a.orb=a.orb||{};a.orb.figState=b})()},deserialise:function(b){var a={};b.replace(/([a-z]{2}):([0-9]+)/g,function(){a[RegExp.$1]=+RegExp.$2});return a}}})();fig.manager.include();/*]]>*/</script>
 <script type="text/javascript"> define('orb/cookies', function() { return window.bbccookies; }); define('orb/fig', function() { return window.orb.fig; }); window.orb.fig.load = function (callback) { callback(window.orb.fig); }; </script> <script type="text/javascript"> (function() { window.bbcpage = { loadModule: function(deps) { return new Promise(function (resolve, reject) { window.require(deps, function () { resolve.apply(this, arguments); }, function (error) { reject(error); }); }) }, loadCSS: function (url, timeout) { return window.bbcpage.loadModule(['orb/lib/_$']) .then(function($) { return new Promise(function(resolve, reject) { var stylesheet = loadCSS(url); $.onloadCSS(stylesheet, function() { resolve(); }); if (timeout) { setTimeout(function () { reject(); }, timeout); } }); }); }, getLanguage: function() { return new Promise(function(resolve, reject) { resolve('cy-GB'); }) }, trackRegion: function (region, labels) { return window.bbcpage.loadModule(['istats-1']) .then(function(istats) { var trackLabels = { region: region }; for (var label in labels) { trackLabels[label] = labels[label]; } var linkType = labels.linkType || 'internal'; istats.track(linkType, trackLabels); }); } }; var sanitiseCountry = function(country) { return country ? country.replace(/ /g, '') : undefined; }; var countryMatches = function(country, validCountries) { return country && typeof(country) === 'string' ? validCountries.indexOf(country.toUpperCase()) !== -1 : false; }; window.bbcuser = { getCountry: function() { return window.bbcpage.loadModule(['orb/fig']) .then(function(orbFig) { return new Promise(function(resolve, reject) { orbFig.load(function (fig) { if (fig.geo.isUK()) { resolve('gb'); } else if (fig.geo.isEU()) { resolve('eu'); } else { resolve(undefined); } }, function () { reject('Error determining country. Timeout?'); }); }); }); }, isUKCombined: function(country) { return new Promise(function(resolve, reject) { var uk = country ? countryMatches(sanitiseCountry(country), ["GB", "IM", "JE", "GY"]) : window.orb.fig('uk'); resolve(uk); }); }, isEU: function(country) { return new Promise(function(resolve, reject) { var eu = country ? countryMatches(sanitiseCountry(country), ["AT", "BE", "BG", "CY", "CZ", "DE", "DK", "EE", "ES", "EU", "FI", "FR", "GB", "GR", "HU", "HR", "IE", "IT", "LT", "LU", "LV", "MT", "NL", "PL", "PT", "RO", "SE", "SI", "SK"]) : window.orb.fig('eu'); resolve(eu); }); }, allowsPerformanceCookies: function() { return window.bbcpage.loadModule(['orb/cookies']) .then(function(bbccookies) { return !!bbccookies.cookiesEnabled() && !!bbccookies.readPolicy('performance'); }); }, allowsFunctionalCookies: function() { return window.bbcpage.loadModule(['orb/cookies']) .then(function(bbccookies) { return !!bbccookies.cookiesEnabled() && !!bbccookies.readPolicy('personalisation'); }); }, getCookieValue: function(cookieName) { return window.bbcpage.loadModule(['orb/cookies']) .then(function(bbccookies) { return bbccookies.get(cookieName); }); }, resetCookiesPreferences: function() { return window.bbcpage.loadModule(['orb/cookies']) .then(function(bbccookies) { bbccookies.setDefaultCookiesSingleDomain(); }); }, hasCookiesEnabled: function() { return window.bbcpage.loadModule(['orb/cookies']) .then(function(bbccookies) { return !!bbccookies.cookiesEnabled(); }); }, hasSeenCookieBanner: function() { return new Promise(function(resolve, reject) { resolve(document.cookie.indexOf('ckns_policy') !== -1); }); }, logEvent: function (verb, noun, extraLabels) { return window.bbcuser.allowsPerformanceCookies() .then(function(allowsCookies) { if (allowsCookies) { return window.bbcpage.loadModule(['istats-1']) .then(function(istats) { istats.log(verb, noun, extraLabels); }); } else { throw new Error('User cannot be tracked due to cookies preferences.'); } }); }, }; }()); </script> <!-- Nav Analytics : 95 -->
<script type="text/javascript">window.bbcFlagpoles_istats="ON",require.config({paths:{"istats-1":"//nav.files.bbci.co.uk/nav-analytics/0.1.0-95/js/istats-1","megavolt-client":"//nav.files.bbci.co.uk/nav-analytics/0.1.0-95/js/megavolt-client"},config:{"megavolt-client":{baseUrl:"https://mvt.api.bbc.com"}}}),require(["istats-1","orb/cookies"],function(e,t){if(t.isAllowed("s1")){e.addCollector({name:"default",url:"https://sa.bbc.co.uk/bbc/bbc/s",separator:"&"});var a="newyddion.de-orllewin.story.44647890.page";e.setCountername(a),window.istats_countername&&e.setCountername(window.istats_countername),e.addLabels("ml_name=webmodule&ml_version=95")}});</script>

<script type="text/javascript">/*<![CDATA[*/
    window.bbcFlagpoles_istats = 'ON';
    window.orb = window.orb || {};

    if (typeof bbccookies !== 'undefined' && bbccookies.isAllowed('s1')) {
        var istatsTrackingUrl = '//sa.bbc.co.uk/bbc/bbc/s?name=newyddion.de-orllewin.story.44647890.page&cps_asset_id=44647890&page_type=Story&section=%2Fnewyddion%2Fde-orllewin&first_pub=2018-06-28T18%3A50%3A48%2B00%3A00&last_editorial_update=2018-06-29T08%3A15%3A59%2B00%3A00&curie=ba10b60e-75f4-654f-8630-17ef23ab05f3&title=Galw+am+broses+dendro+wedi+penderfyniad+morlyn+Abertawe&for_nation=us&app_version=1.247.0&bbc_site=news-cymru&pal_route=asset&app_type=responsive&language=cy-GB&pal_webapp=tabloid&prod_name=cymrufyw&app_name=cymrufyw';
        require(['istats-1'], function (istats) {
            var counterName = (window.istats_countername) ? window.istats_countername : istatsTrackingUrl.match(/[\?&]name=([^&]*)/i)[1];
            istats.setCountername(counterName);

            istats.addLabels('cps_asset_id=44647890&page_type=Story&section=%2Fnewyddion%2Fde-orllewin&first_pub=2018-06-28T18%3A50%3A48%2B00%3A00&last_editorial_update=2018-06-29T08%3A15%3A59%2B00%3A00&curie=ba10b60e-75f4-654f-8630-17ef23ab05f3&title=Galw+am+broses+dendro+wedi+penderfyniad+morlyn+Abertawe&for_nation=us&app_version=1.247.0&bbc_site=news-cymru&pal_route=asset&app_type=responsive&language=cy-GB&pal_webapp=tabloid&prod_name=cymrufyw&app_name=cymrufyw');
            var c = (document.cookie.match(/\bckns_policy=(\d\d\d)/) || []).pop() || '';
            istats.addLabels({
                                        'blq_s': '4d',
                    'blq_r': '2.7',
                    'blq_v': 'default',
                    'blq_e': 'pal',
                                        'bbc_mc': (c ? 'ad' + c.charAt(0) + 'ps' + c.charAt(1) + 'pf' + c.charAt(2) : 'not_set')
                }
            );
        });
    }
    /*]]>*/</script>
 <script type="text/javascript">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</script>  <script type="text/javascript">  document.documentElement.className += (document.documentElement.className? ' ' : '') + 'orb-js';  fig.manager.confirm(); </script> <script src="http://static.bbci.co.uk/frameworks/barlesque/3.22.55/orb/4/script/orb/api.min.js"></script> <script src="http://static.bbci.co.uk/frameworks/barlesque/3.22.55/orb/4/script/orb/font.min.js"></script> <script type="text/javascript"> var blq = { environment: function() { return 'live'; } } </script>   <script type="text/javascript"> /*<![CDATA[*/ function oqsSurveyManager(w, flag) { if (flag !== 'OFF' && (w.orb.fig("no") || w.orb.fig("uk"))) { w.document.write('<script type="text/javascript" src="http://static.bbci.co.uk/frameworks/barlesque/3.22.55/orb/4/script/vendor/edr.min.js"><'+'/script>'); } } oqsSurveyManager(window, 'ON'); /*]]>*/ </script>             <!-- BBCDOTCOM template: responsive webservice  -->
        <!-- BBCDOTCOM head --><script type="text/javascript"> /*<![CDATA[*/ var _sf_startpt = (new Date()).getTime(); /*]]>*/ </script><style type="text/css">.bbccom_display_none{display:none;}</style><script type="text/javascript"> /*<![CDATA[*/ var bbcdotcomConfig, googletag = googletag || {}; googletag.cmd = googletag.cmd || []; var bbcdotcom = false; (function(){ if(typeof require !== 'undefined') { require({ paths:{ "bbcdotcom":"http://static.bbci.co.uk/bbcdotcom/1.82.559/script" } }); } })(); /*]]>*/ </script><script type="text/javascript"> /*<![CDATA[*/ var bbcdotcom = { adverts: { keyValues: { set: function() {} } }, advert: { write: function () {}, show: function () {}, isActive: function () { return false; }, layout: function() { return { reset: function() {} } } }, config: { init: function() {}, isActive: function() {}, setSections: function() {}, isAdsEnabled: function() {}, setAdsEnabled: function() {}, isAnalyticsEnabled: function() {}, setAnalyticsEnabled: function() {}, setAssetPrefix: function() {}, setVersion: function () {}, setJsPrefix: function() {}, setSwfPrefix: function() {}, setCssPrefix: function() {}, setConfig: function() {}, getAssetPrefix: function() {}, getJsPrefix: function () {}, getSwfPrefix: function () {}, getCssPrefix: function () {}, isOptimizelyEnabled: function() {} }, survey: { init: function(){ return false; } }, data: {}, init: function() {}, objects: function(str) { return false; }, locale: { set: function() {}, get: function() {} }, setAdKeyValue: function() {}, utils: { addEvent: function() {}, addHtmlTagClass: function() {}, log: function () {} }, addLoadEvent: function() {} }; /*]]>*/ </script><script type="text/javascript"> /*<![CDATA[*/ (function(){ if (typeof orb !== 'undefined' && typeof orb.fig === 'function') { if (orb.fig('ad') && orb.fig('uk') == 0) { bbcdotcom.data = { ads: (orb.fig('ad') ? 1 : 0), stats: (orb.fig('uk') == 0 ? 1 : 0), statsProvider: orb.fig('ap') }; } } else { document.write('<script type="text/javascript" src="'+('https:' == document.location.protocol ? 'https://www.bbc.com' : 'http://tps.bbc.com')+'/wwscripts/data">\x3C/script>'); } })(); /*]]>*/ </script><script type="text/javascript"> /*<![CDATA[*/ (function(){ if (typeof orb === 'undefined' || typeof orb.fig !== 'function') { bbcdotcom.data = { ads: bbcdotcom.data.a, stats: bbcdotcom.data.b, statsProvider: bbcdotcom.data.c }; } if (bbcdotcom.data.ads == 1) { document.write('<script type="text/javascript" src="'+('https:' == document.location.protocol ? 'https://www.bbc.com' : 'http://www.bbc.com')+'/wwscripts/flag">\x3C/script>'); } })(); /*]]>*/ </script><script type="text/javascript"> /*<![CDATA[*/ (function(){ if (window.bbcdotcom && (typeof bbcdotcom.flag == 'undefined' || (typeof bbcdotcom.data.ads !== 'undefined' && bbcdotcom.flag.a != 1))) { bbcdotcom.data.ads = 0; } if (/[?|&]ads/.test(window.location.href) || /(^|; )ads=on; /.test(document.cookie) || /; ads=on(; |$)/.test(document.cookie)) { bbcdotcom.data.ads = 1; bbcdotcom.data.stats = 1; } if (window.bbcdotcom && (bbcdotcom.data.ads == 1 || bbcdotcom.data.stats == 1)) { bbcdotcom.assetPrefix = "http://static.bbci.co.uk/bbcdotcom/1.82.559/"; (function() { var useSSL = 'https:' == document.location.protocol; var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js'; document.write('<scr' + 'ipt src="' + src + '">\x3C/script>'); })(); if (/(sandbox|int)(.dev)*.bbc.co*/.test(window.location.href) || /[?|&]ads-debug/.test(window.location.href) || document.cookie.indexOf('ads-debug=') !== -1) { document.write('<script type="text/javascript" src="http://static.bbci.co.uk/bbcdotcom/1.82.559/script/dist/bbcdotcom.dev.js">\x3C/script>'); } else { document.write('<script type="text/javascript" src="http://static.bbci.co.uk/bbcdotcom/1.82.559/script/dist/bbcdotcom.js">\x3C/script>'); } } })(); /*]]>*/ </script><script type="text/javascript"> if (window.bbcdotcom && bbcdotcom.data.ads == 1) { document.write('<link rel="dns-prefetch" href="//www.googletagservices.com/">'); document.write('<link rel="dns-prefetch" href="//bbc.gscontxt.net/">'); document.write('<link rel="dns-prefetch" href="//tags.crwdcntrl.net/">'); document.write('<link rel="dns-prefetch" href="//ad.crwdcntrl.net/">'); } </script><script type="text/javascript"> if (window.bbcdotcom && bbcdotcom.data.ads == 1) { document.write('<meta name="google-site-verification" content="auTeTTwSt_KBY_4iDoR00Lwb7-qzx1IgzJy6ztaWgEI" />'); } </script><script type="text/javascript"> /*<![CDATA[*/ (function(){ if (window.bbcdotcom && (bbcdotcom.data.ads == 1 || bbcdotcom.data.stats == 1)) { bbcdotcomConfig = {"adFormat":"standard","adKeyword":"","adMode":"smart","adsEnabled":true,"appAnalyticsSections":"newyddion>de-orllewin","asyncEnabled":true,"disableInitialLoad":false,"advertInfoPageUrl":"http:\/\/www.bbc.com\/privacy\/cookies\/international\/","advertisementText":"Advertisement","analyticsEnabled":false,"appName":"tabloid","assetPrefix":"http:\/\/static.bbci.co.uk\/bbcdotcom\/1.82.559\/","customAdParams":[],"customStatsParams":[],"headline":"Galw am broses dendro wedi penderfyniad morlyn Abertawe","id":"44647890","inAssociationWithText":"in association with","keywords":"","language":"","orbTransitional":false,"outbrainEnabled":true,"outbrainSportEnabled":true,"adsenseEnabled":true,"adsportappEnabled":true,"lotameEnabled":true,"platinumEnabled":true,"tlNewsIndexEnabled":false,"tlNewsStoryEnabled":false,"tlNewsFpEnabled":false,"winterOlympicsEnabled":false,"optimizelyEnabled":true,"grapeshotEnabled":true,"palEnv":"live","productName":"","sections":[],"comScoreEnabled":false,"comscoreSite":"bbc","comscoreID":"19293874","comscorePageName":"Galw am broses dendro wedi penderfyniad morlyn Abertawe","slots":"","sponsoredByText":"is sponsored by","adsByGoogleText":"Ads by Google","summary":"Cwmn\u00efau ynni llanw'n parhau i ddatblygu prosiectau er i Lywodraeth y DU wrthod cynllun morlyn Abertawe cwmni TLP.","type":"STORY","features":{"testfeature":{"name":"testfeature","envs":["sandbox","int","test"],"on":true,"options":{},"override":null},"lxadverts":{"name":"lxadverts","envs":[],"on":true,"options":{},"override":null}},"staticBase":"\/bbcdotcom","staticHost":"http:\/\/static.bbci.co.uk","staticVersion":"1.82.559","staticPrefix":"http:\/\/static.bbci.co.uk\/bbcdotcom\/1.82.559","dataHttp":"tps.bbc.com","dataHttps":"www.bbc.com","flagHttp":"www.bbc.co.uk","flagHttps":"www.bbc.co.uk","analyticsHttp":"sa.bbc.com","analyticsHttps":"ssa.bbc.com"}; bbcdotcom.config.init(bbcdotcomConfig, bbcdotcom.data, window.location, window.document); bbcdotcom.config.setAssetPrefix("http://static.bbci.co.uk/bbcdotcom/1.82.559/"); bbcdotcom.config.setVersion("1.82.559"); document.write('<!--[if IE 7]><script type="text/javascript">bbcdotcom.config.setIE7(true);\x3C/script><![endif]-->'); document.write('<!--[if IE 8]><script type="text/javascript">bbcdotcom.config.setIE8(true);\x3C/script><![endif]-->'); document.write('<!--[if IE 9]><script type="text/javascript">bbcdotcom.config.setIE9(true);\x3C/script><![endif]-->'); if (/[?|&]ex-dp/.test(window.location.href) || document.cookie.indexOf('ex-dp=') !== -1) { bbcdotcom.utils.addHtmlTagClass('bbcdotcom-ex-dp'); } } })(); /*]]>*/ </script><script type="text/javascript"> var initOptimizely = (function(isEnabled){ if(!isEnabled) return; var logger = window.bbcdotcom.Logger('bbcdotcom:head:optimizely'); /* Allow Optimizely in these paths */ var allowPaths = ['/', '/wwhp']; /* Only run on optimizely on homepage */ if (bbcdotcom.utils && allowPaths.indexOf(window.location.pathname) !== -1 && window.bbccookies && bbccookies.readPolicy('performance') ){ /* set correct OptimizelyURL for prod or sandbox */ var optimizelyURL = "https://cdn.optimizely.com/public/4621041136/s/bbccom_sandbox.js"; if(window.location.hostname === 'www.bbc.com') { optimizelyURL = "https://cdn.optimizely.com/public/4621041136/s/bbccom_prod.js"; } /* Set cookie to 1 year */ window['optimizely'] = window['optimizely'] || []; window['optimizely'].push({ "type": "cookieExpiration", "cookieExpirationDays": 365 }); /* Require Optimizely script and initialize tests */ require(['jquery-1', optimizelyURL], function($) { var optimizely = window['optimizely']; /* Start optimizely experiments */ /* End optimizely experiments */ }); } })( bbcdotcom.config.isOptimizelyEnabled() ); </script><script type="text/javascript"> /*<![CDATA[*/ if ( window.bbcdotcom && bbcdotcom.data && bbcdotcom.data.ads && bbcdotcom.data.ads == 1 && bbcdotcom.config && bbcdotcom.config.isGrapeshotEnabled && bbcdotcom.config.isGrapeshotEnabled() && bbcdotcom.config.isWorldService && !bbcdotcom.config.isWorldService() ) { var gs_channels="DEFAULT"; (function () { var gssrc = "", gsurl = window.location.href.split("?")[0]; gssrc = 'https://bbc.gscontxt.net/?url='+encodeURIComponent(gsurl); document.write('<scr' + 'ipt src="' + gssrc + '">\x3C/script>'); bbcdotcom.gsTimerStart = (new Date()).getTime(); bbcdotcom.config.setGrapeshotActive(true); })(); } /*]]>*/ </script><script type="text/javascript"> /*<![CDATA[*/ (function() { window.bbcdotcom.head = true; }()); /*]]>*/ </script>             <!--Searchbox:137-->  <script type="text/javascript">
  // Globally available search context
  window.SEARCHBOX={"variant":"default","locale":"cy","navSearchboxStaticPrefix":"//nav.files.bbci.co.uk/searchbox/1.0.0-137","searchboxAppStaticPrefix":"//search.files.bbci.co.uk/searchbox-app/1.0.21","searchFormHtml":"<div tabindex=\"-1\" data-reactid=\".18jgjgxqf40\" data-react-checksum=\"-1015011647\"><div data-reactid=\".18jgjgxqf40.0\"><section class=\"se-searchbox-panel\" data-reactid=\".18jgjgxqf40.0.0\"><div class=\"se-g-wrap\" data-reactid=\".18jgjgxqf40.0.0.0\"><div class=\"se-g-layout\" data-reactid=\".18jgjgxqf40.0.0.0.0\"><div class=\"se-g-layout__item se-searchbox-title\" aria-hidden=\"true\" data-reactid=\".18jgjgxqf40.0.0.0.0.0\">search</div><div class=\"se-g-layout__item se-searchbox\" data-reactid=\".18jgjgxqf40.0.0.0.0.1\"><form accept-charset=\"utf-8\" id=\"searchboxDrawerForm\" method=\"get\" action=\"https://search.bbc.co.uk/search\" data-reactid=\".18jgjgxqf40.0.0.0.0.1.0\"><label class=\"se-searchbox__input\" for=\"se-searchbox-input-field\" data-reactid=\".18jgjgxqf40.0.0.0.0.1.0.0\"><span class=\"se-sr-only\" data-reactid=\".18jgjgxqf40.0.0.0.0.1.0.0.0\">Search Term</span><input name=\"q\" type=\"text\" value=\"\" id=\"se-searchbox-input-field\" class=\"se-searchbox__input__field\" maxlength=\"512\" autocomplete=\"off\" autocorrect=\"off\" autocapitalize=\"off\" spellcheck=\"false\" tabindex=\"0\" data-reactid=\".18jgjgxqf40.0.0.0.0.1.0.0.1\"/></label><input type=\"hidden\" name=\"scope\" value=\"\" data-reactid=\".18jgjgxqf40.0.0.0.0.1.0.2\"/><button type=\"submit\" class=\"se-searchbox__submit\" tabindex=\"0\" data-reactid=\".18jgjgxqf40.0.0.0.0.1.0.3\">Search</button><button type=\"button\" class=\"se-searchbox__clear se-searchbox__clear--visible\" tabindex=\"0\" data-reactid=\".18jgjgxqf40.0.0.0.0.1.0.4\">Close</button></form></div></div></div></section><div aria-live=\"polite\" aria-atomic=\"true\" class=\"se-suggestions-container\" data-reactid=\".18jgjgxqf40.0.1\"><section class=\"se-g-wrap\" data-reactid=\".18jgjgxqf40.0.1.0\"></section></div></div></div>","searchScopePlaceholder":"<input type=\"hidden\" name=\"scope\" id=\"orb-search-scope\" value=\"cymru\">","searchScopeParam":"?scope=cymru","searchScopeTemplate":"cymru","searchPlaceholderWrapperStart":"","searchPlaceholderWrapperEnd":""};
  window.SEARCHBOX.suppress = false;
  window.SEARCHBOX.searchScope = SEARCHBOX.searchScopeTemplate.split('-')[0];
</script>
<link rel="stylesheet" href="//nav.files.bbci.co.uk/searchbox/1.0.0-137/css/main.css">
<!--[if IE 8]>
  <script type="text/javascript" src="//nav.files.bbci.co.uk/searchbox/1.0.0-137/script/html5shiv.min.js"></script>
  <script type="text/javascript">window['searchboxIEVersion'] = 8;</script>
  <link rel="stylesheet" href="//nav.files.bbci.co.uk/searchbox/1.0.0-137/css/ie8.css">
<![endif]-->
<!--[if IE 9]>
  <script type="text/javascript">window['searchboxIEVersion'] = 9;</script>
<![endif]-->
  <!--NavID:0.2.0-152--> <link rel="stylesheet" href="//static.bbc.co.uk/id/0.37.24/style/id-cta.css" /> <link rel="stylesheet" href="//static.bbc.co.uk/id/0.37.24/style/id-cta-v5.css" /> <!--[if IE 8]><link href="//static.bbc.co.uk/id/0.37.24/style/ie8.css" rel="stylesheet"/> <![endif]--> <script type="text/javascript"> /* <![CDATA[ */ var map = {};  if (typeof(map['jssignals-1']) == 'undefined') { map['jssignals-1'] = 'https://static.bbc.co.uk/frameworks/jssignals/0.3.6/modules/jssignals-1'; }  require({paths: map}); /* ]]> */ </script>   <script src="//static.bbc.co.uk/id/0.37.24/modules/idcta/dist/idcta-1.min.js"></script>  <script type="text/javascript"> (function () { if (!window.require) { throw new Error('idcta: could not find require module'); } if(typeof(map) == 'undefined') { var map = {}; } if(!!document.createElementNS && !!document.createElementNS('http://www.w3.org/2000/svg', "svg").createSVGRect) { document.documentElement.className += ' id-svg'; } var ptrt = RegExp("[\\?&]ptrt=([^&#]*)").exec(document.location.href); var ENDPOINT_URL = '//' + ((window.location.protocol == "https:") ? ('ssl.bbc.co.uk').replace("www.", "ssl.") : ('ssl.bbc.co.uk').replace("ssl.", "www.")); var ENDPOINT_CONFIG = ('/idcta/config?callback&amp;locale=en-GB&ptrt=' + encodeURI((ptrt ? ptrt[1] : document.location.href))).replace(/\&amp;/g, '&'); var ENDPOINT_TRANSLATIONS = '/idcta/translations?callback&locale=en-GB'; map['idapp-1'] = '//static.bbc.co.uk/idapp/0.72.58/modules/idapp/idapp-1'; map['idcta'] = '//static.bbc.co.uk/id/0.37.24/modules/idcta'; map['idcta/config'] = [ENDPOINT_URL + ENDPOINT_CONFIG, '//static.bbc.co.uk/id/0.37.24/modules/idcta/fallbackConfig']; map['idcta/translations'] = [ENDPOINT_URL + ENDPOINT_TRANSLATIONS, '//static.bbc.co.uk/id/0.37.24/modules/idcta/fallbackTranslations']; require({paths: map}); /* * Temporary code * To be removed when old id-statusbar-config is no longer supported */ define('id-statusbar-config', ['idcta/id-config'], function(conf) { return conf; }); define('idcta/id-statusbar-config', ['idcta/id-config'], function(conf) { return conf; }); })(); </script>

    <link rel="stylesheet" href="//mybbc.files.bbci.co.uk/notification-ui/3.8.4/css/main.min.css"/>
             
        <link type="text/css" rel="stylesheet" href="http://static.bbci.co.uk/news/1.247.02790/stylesheets/services/cymrufyw/core.css">
    <!--[if lt IE 9]>
        <link type="text/css" rel="stylesheet" href="http://static.bbci.co.uk/news/1.247.02790/stylesheets/services/cymrufyw/old-ie.css">
        <script src="http://static.bbci.co.uk/news/1.247.02790/js/vendor/html5shiv/html5shiv.js"></script>
    <![endif]-->
 <script id="news-loader">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</script>  <script type="text/javascript"> /*<![CDATA[*/ bbcdotcom.init({adsToDisplay:['leaderboard', 'mpu'], asyncEnabled:true }); /*]]>*/ </script>      <noscript><link href="http://static.bbci.co.uk/news/1.247.02790/icons/generated/icons.fallback.css" rel="stylesheet"></noscript>

                
    
        <meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=1">

                    
    </head>
<!--[if IE]><body id="asset-type-sty" class="ie device--feature"><![endif]-->
<!--[if !IE]>--><body id="asset-type-sty" class="device--feature"><!--<![endif]-->
    <div class="direction" >

    
             <!-- BBCDOTCOM bodyFirst --><div id="bbccom_interstitial_ad" class="bbccom_display_none"></div><div id="bbccom_interstitial" class="bbccom_display_none"><script type="text/javascript"> /*<![CDATA[*/ (function() { if (window.bbcdotcom && bbcdotcom.config.isActive('ads')) { googletag.cmd.push(function() { googletag.display('bbccom_interstitial'); }); } }()); /*]]>*/ </script></div><div id="bbccom_wallpaper_ad" class="bbccom_display_none"></div><div id="bbccom_wallpaper" class="bbccom_display_none"><script type="text/javascript"> /*<![CDATA[*/ (function() { var wallpaper; if (window.bbcdotcom && bbcdotcom.config.isActive('ads')) { if (bbcdotcom.config.isAsync()) { googletag.cmd.push(function() { googletag.display('bbccom_wallpaper'); }); } else if (typeof googletag !== "undefined" && typeof googletag.display === "function") { googletag.display("wallpaper"); } wallpaper = bbcdotcom.adverts.adRegister.getAd('wallpaper'); } }()); /*]]>*/ </script></div><script type="text/javascript"> /*<![CDATA[*/ (function() { if (window.bbcdotcom && bbcdotcom.config.isActive('ads')) { document.write(unescape('%3Cscript id="gnlAdsEnabled" class="bbccom_display_none"%3E%3C/script%3E')); } if (window.bbcdotcom && bbcdotcom.config.isActive('analytics')) { document.write(unescape('%3Cscript id="gnlAnalyticsEnabled" class="bbccom_display_none"%3E%3C/script%3E')); } }()); /*]]>*/ </script><script type="text/javascript"> /*<![CDATA[*/ (function() { window.bbcdotcom.bodyFirst = true; }()); /*]]>*/ </script> <div id="cookiePrompt"></div> <div id="blq-global"> <div id="blq-pre-mast">  </div> </div>  <noscript><p style="position: absolute; top: -999em"><img src="https://sa.bbc.co.uk/bbc/bbc/s?name=newyddion.de-orllewin.story.44647890.page&amp;ml_name&#x3D;webmodule&amp;ml_version&#x3D;95&amp;blq_js_enabled=0&blq_s=4d&blq_r=2.7&blq_v=default&blq_e=pal&cps_asset_id=44647890&page_type=Story&section=%2Fnewyddion%2Fde-orllewin&first_pub=2018-06-28T18%3A50%3A48%2B00%3A00&last_editorial_update=2018-06-29T08%3A15%3A59%2B00%3A00&curie=ba10b60e-75f4-654f-8630-17ef23ab05f3&title=Galw+am+broses+dendro+wedi+penderfyniad+morlyn+Abertawe&for_nation=us&app_version=1.247.0&bbc_site=news-cymru&pal_route=asset&app_type=responsive&language=cy-GB&pal_webapp=tabloid&prod_name=cymrufyw&app_name=cymrufyw" height="1" width="1" alt=""></p></noscript>  <!-- Begin iStats 20100118 (UX-CMC 1.1009.3) --> <script type="text/javascript">/*<![CDATA[*/ if (typeof bbccookies !== 'undefined' && bbccookies.isAllowed('s1')) { (function () { require(['istats-1'], function (istats) { istatsTrackingUrl = istats.getDefaultURL(); if (istats.isEnabled() && bbcFlagpoles_istats === 'ON') { sitestat(istatsTrackingUrl); } else { window.ns_pixelUrl = istatsTrackingUrl; /* used by Flash library to track */ } function sitestat(n) { var j = document, f = j.location, b = ""; if (j.cookie.indexOf("st_ux=") != -1) { var k = j.cookie.split(";"); var e = "st_ux", h = document.domain, a = "/"; if (typeof ns_ != "undefined" && typeof ns_.ux != "undefined") { e = ns_.ux.cName || e; h = ns_.ux.cDomain || h; a = ns_.ux.cPath || a } for (var g = 0, f = k.length; g < f; g++) { var m = k[g].indexOf("st_ux="); if (m != -1) { b = "&" + decodeURI(k[g].substring(m + 6)) } } bbccookies.set(e + "=; expires=" + new Date(new Date().getTime() - 60).toGMTString() + "; path=" + a + "; domain=" + h); } window.ns_pixelUrl = n;  } }); })(); } else { window.istats = {enabled: false}; } /*]]>*/</script> <!-- End iStats (UX-CMC) -->  
 <!--[if (gt IE 8) | (IEMobile)]><!--> <header id="orb-banner" role="banner"> <!--<![endif]--> <!--[if (lt IE 9) & (!IEMobile)]> <![if (IE 8)]> <header id="orb-banner" role="banner" class="orb-old-ie orb-ie8"> <![endif]> <![if (IE 7)]> <header id="orb-banner" role="banner" class="orb-old-ie orb-ie7"> <![endif]> <![if (IE 6)]> <header id="orb-banner" role="banner" class="orb-old-ie orb-ie6"> <![endif]> <![endif]--> <div id="orb-header"  class="orb-nav-pri orb-nav-pri-white b-header--white--black orb-nav-empty"  > <div class="orb-nav-pri-container b-r b-g-p"> <div class="orb-nav-section orb-nav-blocks"> <a href="/"> <img  src="http://static.bbci.co.uk/frameworks/barlesque/3.22.55/orb/4/img/bbc-blocks-dark.png" width="84" height="24" alt="BBC" /> </a> </div> <section> <div class="orb-skip-links"> <h2>Linciau mynediad</h2> <ul>  <li><a href="#page">Neidio i'r cynnwys</a></li>  <li><a id="orb-accessibility-help" href="/accessibility/">Cymorth Hygyrchedd</a></li> </ul> </div> </section>  <div id="mybbc-wrapper" class="orb-nav-section orb-nav-id orb-nav-focus"> <div id="idcta-statusbar" class="orb-nav-section orb-nav-focus"> <a id="idcta-link" href="https://account.bbc.com/account?ptrt=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890"> <span id="idcta-username">BBC iD</span> </a> </div>  <script type="text/javascript"> require(['idcta/statusbar'], function(statusbar) { new statusbar.Statusbar({"id":"idcta-statusbar","publiclyCacheable":true}); }); </script>

    <a id="notification-link" class="js-notification-link animated three" href="#">
        <span class="hidden-span">Notifications</span>
        <div class="notification-link--triangle"></div>
        <div class="notification-link--triangle"></div>
        <span id="not-num"></span>
    </a>
 </div>  <nav role="navigation" class="orb-nav"> <div class="orb-nav-section orb-nav-links orb-nav-focus" id="orb-nav-links"> <h2>Llywio drwy’r BBC</h2> <ul>    <li  class="orb-nav-home orb-d"  > <a href="http://www.bbc.co.uk/">Hafan</a> </li>    <li  class="orb-nav-homedotcom orb-w"  > <a href="http://www.bbc.com/">Hafan</a> </li>    <li  class="orb-nav-news orb-d"  > <a href="http://www.bbc.co.uk/newyddion/">Newyddion</a> </li>    <li  class="orb-nav-newsdotcom orb-w"  > <a href="http://www.bbc.com/news">Newyddion</a> </li>    <li  class="orb-nav-sport"  > <a href="/sport/">Sport</a> </li>    <li  class="orb-nav-weather"  > <a href="/weather/cy/">Tywydd</a> </li>    <li  class="orb-nav-shop orb-w"  > <a href="http://shop.bbc.com/">Shop</a> </li>    <li  class="orb-nav-earthdotcom orb-w"  > <a href="http://www.bbc.com/earth/">Earth</a> </li>    <li  class="orb-nav-travel-dotcom orb-w"  > <a href="http://www.bbc.com/travel/">Travel</a> </li>    <li  class="orb-nav-capital orb-w"  > <a href="http://www.bbc.com/capital/">Capital</a> </li>    <li  class="orb-nav-iplayer orb-d"  > <a href="/iplayer/cy/">iPlayer</a> </li>    <li  class="orb-nav-culture orb-w"  > <a href="http://www.bbc.com/culture/">Culture</a> </li>    <li  class="orb-nav-autos orb-w"  > <a href="http://www.bbc.com/autos/">Autos</a> </li>    <li  class="orb-nav-future orb-w"  > <a href="http://www.bbc.com/future/">Dyfodol</a> </li>    <li  class="orb-nav-tv"  > <a href="/tv/">TV</a> </li>    <li  class="orb-nav-radio"  > <a href="/radio/">Radio</a> </li>    <li  class="orb-nav-cbbc"  > <a href="/cbbc">CBBC</a> </li>    <li  class="orb-nav-cbeebies"  > <a href="/cbeebies">CBeebies</a> </li>    <li  class="orb-nav-food"  > <a href="/food/">Food</a> </li>    <li  > <a href="/iwonder">iWonder</a> </li>    <li  > <a href="/education">Bitesize</a> </li>    <li  class="orb-nav-travel orb-d"  > <a href="/travel/">Teithio</a> </li>    <li  class="orb-nav-music"  > <a href="/music/">Music</a> </li>    <li  class="orb-nav-earth orb-d"  > <a href="http://www.bbc.com/earth/">Earth</a> </li>    <li  class="orb-nav-arts"  > <a href="/arts/">Celfyddydau</a> </li>    <li  class="orb-nav-makeitdigital"  > <a href="/makeitdigital">Make It Digital</a> </li>    <li  > <a href="/taster">Taster</a> </li>    <li  class="orb-nav-nature orb-w"  > <a href="/nature/">Nature</a> </li>    <li  class="orb-nav-local"  > <a href="/local/">Local</a> </li>    <li  class="orb-nav-tomorrowsworld orb-d"  > <a href="/tomorrowsworld">Tomorrow's World</a> </li>    <li id="orb-nav-more"><a href="#orb-footer" data-alt="Mwy">Menu<span class="orb-icon orb-icon-arrow"></span></a></li> </ul> </div> </nav>   <div class="orb-nav-section orb-nav-search"> <a class="orb-search__button" href="https://search.bbc.co.uk/search?scope&#x3D;cymru" title="Search the BBC">Chwilio</a>

<form class="b-f" id="orb-search-form" role="search" method="get"
      action="https://search.bbc.co.uk/search" accept-charset="utf-8">
    <div>
        <input type="hidden" name="scope" id="orb-search-scope" value="cymru">
        <label for="orb-search-q">Search the BBC</label>
            <input
                id="orb-search-q"
                type="text"
                autocomplete="off"
                autocorrect="off"
                autocapitalize="off"
                spellcheck="false"
                name="q"
                placeholder="Chwilio"
            >
            <button id="orb-search-button" class="orb-search__button">Search the BBC</button>
            <input type="hidden" name="suggid" id="orb-search-suggid"/>
    </div>
</form>


 </div>  </div> <div id="orb-panels"  > <script type="text/template" id="orb-panel-template"><![CDATA[ <div id="orb-panel-<%= panelname %>" class="orb-panel" aria-labelledby="orb-nav-<%= panelname %>"> <div class="orb-panel-content b-g-p b-r"> <%= panelcontent %> </div> </div> ]]></script> </div> </div> </header> <!-- Styling hook for shared modules only --> <div id="orb-modules">             
    <div id="site-container">

    <!--[if lt IE 9]>
<div class="browser-notify">
    <div class="browser-notify__banner">
        <div class="browser-notify__icon"></div>
        <span>Mae'r safle yma'n fwy addas ar gyfer porwyr gwe modern. Nid yw popeth yn gweithio'n iawn ar y fersiwn yma o Internet Explorer</span>
    </div>
</div>
<![endif]-->            <div class="site-brand site-brand--height" role="banner" aria-label="BBC Cymru Fyw">
                        <div class="site-brand-inner site-brand-inner--height">
                <div class="navigation navigation--primary">
                    <a href="/cymrufyw" id="brand">
            <svg class="brand__svg" width="141" height="35" focusable="false" aria-hidden="true">
            <image xlink:href="http://static.bbci.co.uk/news/1.247.02790/img/brand/generated/cymrufyw-light.svg" src="http://static.bbci.co.uk/news/1.247.02790/img/brand/generated/cymrufyw-light.png" width="100%" height="100%"/>
        </svg>
        <span class="off-screen">Cymru Fyw</span>
        </a>                    <h2 class="navigation__heading off-screen">BBC Cymru Fyw Navigation</h2>
                    <div class="nav-buttons">
                                                <a href="#core-navigation" class="navigation__section navigation__section--core" data-event="header">
                            <div class="navigation__section--icon">
                                <span class="off-screen">Adrannau</span>
                            </div>
                        </a>
                    </div>
                </div>
            </div>
                        

<div class="navigation navigation--wide">
    <ul class="navigation-wide-list" role="navigation" aria-label="BBC Cymru Fyw" data-panel-id="js-navigation-panel-primary">
                    <li>
                <a href="/cymrufyw" class="navigation-wide-list__link">
                    <span>Hafan</span>
                </a>
                            </li>
                    <li>
                <a href="/cymrufyw/cylchgrawn" class="navigation-wide-list__link">
                    <span>Cylchgrawn</span>
                </a>
                            </li>
                    <li>
                <a href="/cymrufyw/gwleidyddiaeth" class="navigation-wide-list__link">
                    <span>Gwleidyddiaeth</span>
                </a>
                            </li>
                    <li>
                <a href="/cymrufyw/gogledd-orllewin" class="navigation-wide-list__link">
                    <span>Gog-Orll</span>
                </a>
                            </li>
                    <li>
                <a href="/cymrufyw/gogledd-ddwyrain" class="navigation-wide-list__link">
                    <span>Gog-Ddwy</span>
                </a>
                            </li>
                    <li>
                <a href="/cymrufyw/canolbarth" class="navigation-wide-list__link">
                    <span>Canolbarth</span>
                </a>
                            </li>
                    <li class="selected">
                <a href="/cymrufyw/de-orllewin" class="navigation-wide-list__link navigation-arrow--open">
                    <span>De-Orll</span>
                </a>
                 <span class="off-screen">selected</span>            </li>
                    <li>
                <a href="/cymrufyw/de-ddwyrain" class="navigation-wide-list__link">
                    <span>De-Ddwy</span>
                </a>
                            </li>
                    <li>
                <a href="/news/wales" class="navigation-wide-list__link navigation-wide-list__link--last">
                    <span>Wales News</span>
                </a>
                            </li>
            </ul>
</div>

                    </div>
            
    
    
                        <div class="container-width-only">
                                                </div>
            
         <div id="page" class="configurable story " data-story-id="44647890">                         <div class="page__head">
                                                                            <div class="bbccom_slot old-ads" data-comp-meta="{&quot;id&quot;:&quot;comp-adverts&quot;,&quot;type&quot;:&quot;adverts&quot;,&quot;handler&quot;:&quot;adverts&quot;,&quot;deviceGroups&quot;:null,&quot;opts&quot;:{&quot;assetId&quot;:&quot;44647890&quot;,&quot;ad_type&quot;:&quot;leaderboard&quot;},&quot;template&quot;:&quot;\/component\/adverts&quot;}">
    <div class="bbccom_advert bbccom_display_none">
        <script type="text/javascript">
            if (typeof bbcdotcom !== 'undefined' && typeof bbcdotcom.objects !== 'undefined' &&
                    bbcdotcom.objects('bbcdotcom.adverts.slot')) {
                bbcdotcom.adverts.slot('leaderboard', [1,2,3,4]);
            }
        </script>
    </div>
    <script type="text/javascript">
        if (typeof bbcdotcom !== 'undefined' && typeof bbcdotcom.objects !== 'undefined' &&
                bbcdotcom.objects('bbcdotcom.adverts.slot')) {
            bbcdotcom.adverts.adRegister.getCurrentAd().show();
        }
    </script>
</div>
                                                                        </div>
             <div role="main"> <div class="container-width-only">       </div>      <div class="container">                         <div class="column--single">
                                                                            <div aria-hidden="true" class="column-clearfix ">
	<div class="">
		<div class="vocab-tool vocab-tool--show ">
			<div class="vocab-toggle js-vocab-toggle" aria-disabled="true" data-vocab-key="38fd95d8-d5f9-43e0-a215-c5b0072b1c1c" 
			title="Click to turn Vocab on. Then, view English translations by hovering over underlined text. 

Cliciwch i droi Vocab ymlaen. Yna, gallwch hofran dros y geiriau unigol i weld cyfieithiadau.">
				<div class="vocab-toggle__spinner"></div>
				<div class="vocab-toggle__icon"></div>
				<div class="vocab-toggle__title">
					VOCAB
				</div> 
			</div>

			<div class="vocab-alert js-vocab-alert" title="Error/Gwall">
				<span class="vocab-alert__text">Error/Gwall</span>
				<div class="vocab-alert__close"></div>
			</div>

			<a class="vocab-faq" data-entityid="vocab-faq" href="http://www.bbc.co.uk/cymrufyw/34290052"></a>
			<div class="vocab_textbutton" aria-hidden="true"></div>
		</div>
	</div>
</div>                                                                        </div>
              <div class="container--primary-and-secondary-columns column-clearfix">                         <div class="column--primary">
                                                                            
<div class="story-body">
    <h1 class="story-body__h1">Galw am broses dendro wedi penderfyniad morlyn Abertawe</h1>

        <div class="with-extracted-share-icons">
        <div class="story-body__mini-info-list-and-share">
            <div class="story-body__mini-info-list-and-share-row">
                <div class="mini-info-list-wrap">
                                            <ul class="mini-info-list">
    <li class="mini-info-list__item"><div class="date date--v2" data-seconds="1530260159" data-datetime="29 Mehefin 2018">29 Mehefin 2018</div></li>
</ul>
                                    </div>
                                    <div class="share-tools--no-event-tag">
                        

    <div id="comp-pattern-library-4" class="distinct-component-group container-twite">
        
            <ul class="sharetools">
        <li class="twite__channel-out twite__channel-out--desktop twite__channel-out--facebook twite__channel-click-extracted--facebook twite__list-elements" aria-hidden="true">
            <a class="extracted__channel-link extracted__channel-link--facebook"onclick="window.open('http://www.facebook.com/dialog/feed?app_id=58567469885&amp;redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fnews%2Fspecial%2Fshared%2Fvj_sharetools%2Ffb_red_uri.html&amp;link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FSThisFB&amp;display=popup', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=555,height=615').opener = null" href='#'  tabindex="-1">
                    <span class="extracted__icon extracted__icon--facebook" data-platform="facebook">
                    <svg class="extracted-svg ex-facebook" viewBox="-17 -13 44 44" enable-background="new 0 0 44 44" width="44px" height="44px" aria-hidden="true" focusable="false">
                    <g><path d="M5.73,17 L5.73,9.246 L8.333,9.246 L8.723,6.223 L5.73,6.223 L5.73,4.294 C5.73,3.419 5.973,2.823 7.228,2.823 L8.828,2.822 L8.828,0.119 C8.551,0.082 7.601,0 6.496,0 C4.189,0 2.609,1.408 2.609,3.995 L2.609,6.223 L0,6.223 L0,9.246 L2.609,9.246 L2.609,17 L5.73,17 Z"/></g>
                        </svg>
                    </span>
                <span class="off-screen">Rhannu hwn ar Facebook</span>
            </a>
        </li>
        <li class="twite__channel-out twite__channel-out--desktop twite__channel-out--messengerdesktop twite__channel-click-extracted--messengerdesktop twite__list-elements" aria-hidden="true">
            <a class="extracted__channel-link extracted__channel-link--messengerdesktop"onclick="window.open('http://www.facebook.com/dialog/send?app_id=58567469885&amp;redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fnews%2Fspecial%2Fshared%2Fvj_sharetools%2Ffb_red_uri.html&amp;link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FSThisFB&amp;display=popup', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=645,height=580').opener = null" href='#'  tabindex="-1">
                    <span class="extracted__icon extracted__icon--messengerdesktop" data-platform="messengerdesktop">
                    <svg class="extracted-svg ex-messengerdesktop" viewBox="-14 -13 44 44" enable-background="new 0 0 44 44" width="44px" height="44px" aria-hidden="true" focusable="false">
                    <g><path d="M9.84804801,11.1721834 L7.54389655,8.77893955 L3.1059828,11.2323207 L7.97153994,6.06941781 L10.2756914,8.46377529 L14.7136051,6.00928046 L9.84804801,11.1721834 Z M8.90923715,0 C3.98911093,0 0,3.73074306 0,8.33125039 C0,10.9494525 1.29183939,13.2847862 3.3097816,14.8116068 L3.3097816,18 L6.35117243,16.3139269 C7.16079936,16.5399988 8.02054074,16.6625008 8.90923715,16.6625008 C13.830477,16.6625008 17.8184743,12.9328714 17.8184743,8.33125039 C17.8184743,3.73074306 13.830477,0 8.90923715,0 L8.90923715,0 Z"/></g>
                        </svg>
                    </span>
                <span class="off-screen">Rhannu hwn ar Messenger</span>
            </a>
        </li>
        <li class="twite__channel-out twite__channel-out--desktop twite__channel-out--twitter twite__channel-click-extracted--twitter twite__list-elements" aria-hidden="true">
            <a class="extracted__channel-link extracted__channel-link--twitter"onclick="window.open('https://twitter.com/intent/tweet?text=BBC%20Cymru%20Fyw%20-%20Galw%20am%20broses%20dendro%20wedi%20penderfyniad%20morlyn%20Abertawe&amp;url=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=550,height=250').opener = null" href='#' class=shortenUrl data-social-url=https://twitter.com/intent/tweet?text=BBC+Cymru+Fyw+-+Galw+am+broses+dendro+wedi+penderfyniad+morlyn+Abertawe&amp;amp;url= data-target-url=http://www.bbc.co.uk/cymrufyw/44647890 tabindex="-1">
                    <span class="extracted__icon extracted__icon--twitter" data-platform="twitter">
                    <svg class="extracted-svg ex-twitter" viewBox="-13 -15 44 44" enable-background="new 0 0 44 44" width="44px" height="44px" aria-hidden="true" focusable="false">
                    <g><path d="M5.80573373,15 C12.7721527,15 16.581877,9.22887915 16.581877,4.22385671 C16.581877,4.06002242 16.581877,3.89618812 16.5714931,3.73466135 C17.3122088,3.19816171 17.9525471,2.53359441 18.4602026,1.77326482 C17.7690988,2.08016568 17.0364595,2.28092039 16.28536,2.36976011 C17.0756874,1.89671742 17.6675677,1.15138674 17.9502395,0.274527115 C17.2072164,0.715264453 16.3938137,1.02678037 15.5457981,1.19407596 C14.1105174,-0.331198284 11.7118448,-0.405039095 10.1865706,1.0290879 C9.20241101,1.95440555 8.78590269,3.33315194 9.09049603,4.64844138 C6.04571636,4.4961447 3.20861397,3.05740266 1.28529161,0.691035437 C0.280364327,2.42167943 0.793788713,4.63574999 2.45751448,5.74682343 C1.85525036,5.72951699 1.26567764,5.56683646 0.738408105,5.27262698 L0.738408105,5.32108501 C0.739561868,7.12441605 2.00985456,8.67622684 3.77741896,9.03389326 C3.2201516,9.18618993 2.63519393,9.20811142 2.06754269,9.09850397 C2.56366064,10.6410847 3.98509624,11.6979313 5.60613279,11.7290828 C4.26430681,12.7824682 2.60750362,13.3547344 0.902242404,13.3535807 C0.601110348,13.3524269 0.299978293,13.3339667 7.10542736e-15,13.2982001 C1.73295152,14.4104273 3.74742113,15 5.80573373,14.9965387"/></g>
                        </svg>
                    </span>
                <span class="off-screen">Rhannu hwn ar Twitter</span>
            </a>
        </li>
        <li class="twite__channel-out twite__channel-out--desktop twite__channel-out--email twite__channel-click-extracted--email twite__list-elements" aria-hidden="true">
            <a class="extracted__channel-link extracted__channel-link--email"href='mailto:?subject=Rhannwyd%20o%20wefan%20Cymrufyw%20y%20BBC&amp;body=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890'  tabindex="-1">
                    <span class="extracted__icon extracted__icon--email" data-platform="email">
                    <svg class="extracted-svg ex-email" viewBox="-7 1 27 9" enable-background="new 0 0 44 44" width="44px" height="44px" aria-hidden="true" focusable="false">
                    <g><path d="M11,4.9V9H2V2.1l4.6,5L13.1,0H0.2H0v11h13V2.8L11,4.9z M10.2,2L6.7,5.8L3.2,2H10.2z"/></g>
                        </svg>
                    </span>
                <span class="off-screen">Rhannu hwn ar Ebost</span>
            </a>
        </li>
        <li class="twite__channel-out twite__channel-out--mobile twite__channel-out--facebook twite__channel-click-extracted--facebook twite__list-elements" aria-hidden="true">
            <a class="extracted__channel-link extracted__channel-link--facebook"onclick="window.open('http://www.facebook.com/dialog/feed?app_id=58567469885&amp;redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fnews%2Fspecial%2Fshared%2Fvj_sharetools%2Ffb_red_uri.html&amp;link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FSThisFB&amp;display=popup', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=555,height=615').opener = null" href='#'  tabindex="-1">
                    <span class="extracted__icon extracted__icon--facebook" data-platform="facebook">
                    <svg class="extracted-svg ex-facebook" viewBox="-17 -13 44 44" enable-background="new 0 0 44 44" width="44px" height="44px" aria-hidden="true" focusable="false">
                    <g><path d="M5.73,17 L5.73,9.246 L8.333,9.246 L8.723,6.223 L5.73,6.223 L5.73,4.294 C5.73,3.419 5.973,2.823 7.228,2.823 L8.828,2.822 L8.828,0.119 C8.551,0.082 7.601,0 6.496,0 C4.189,0 2.609,1.408 2.609,3.995 L2.609,6.223 L0,6.223 L0,9.246 L2.609,9.246 L2.609,17 L5.73,17 Z"/></g>
                        </svg>
                    </span>
                <span class="off-screen">Rhannu hwn ar Facebook</span>
            </a>
        </li>
        <li class="twite__channel-out twite__channel-out--mobile twite__channel-out--whatsapp twite__channel-click-extracted--whatsapp twite__list-elements" aria-hidden="true">
            <a class="extracted__channel-link extracted__channel-link--whatsapp"onclick="window.open('whatsapp://send?text=BBC%20Cymru%20Fyw%20%7C%20Galw%20am%20broses%20dendro%20wedi%20penderfyniad%20morlyn%20Abertawe%20-%20http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3Focid%3Dwscymrufyw.chat-apps.in-app-msg.whatsapp.trial.link1_.auin', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=600,height=600').opener = null" href='#'  tabindex="-1">
                    <span class="extracted__icon extracted__icon--whatsapp" data-platform="whatsapp">
                    <svg class="extracted-svg ex-whatsapp" viewBox="-11 -11 44 44" enable-background="new 0 0 44 44" width="44px" height="44px" aria-hidden="true" focusable="false">
                    <g><path d="M0.6 19.4L1.9 14.7C1 13.3 0.6 11.7 0.6 10 0.6 4.8 4.8 0.5 10 0.5 15.2 0.5 19.4 4.8 19.4 10 19.4 15.2 15.2 19.4 10 19.4 8.4 19.4 6.8 19 5.4 18.2L0.6 19.4ZM5.6 16.5L5.9 16.7C7.2 17.4 8.6 17.8 10 17.8 14.3 17.8 17.8 14.3 17.8 10 17.8 5.7 14.3 2.1 10 2.1 5.7 2.1 2.2 5.7 2.2 10 2.2 11.5 2.6 12.9 3.4 14.2L3.6 14.5 2.8 17.2 5.6 16.5Z M7.4 5.6L6.7 5.5C6.6 5.5 6.4 5.6 6.2 5.7 5.9 6 5.5 6.5 5.3 7.1 5.1 8.1 5.4 9.3 6.3 10.5 7.2 11.6 8.8 13.5 11.6 14.4 12.6 14.6 13.3 14.4 13.8 14.1 14.3 13.8 14.6 13.3 14.7 12.8L14.8 12.4C14.8 12.2 14.8 12.1 14.6 12L12.6 11.1C12.4 11 12.3 11 12.2 11.2L11.4 12.2C11.3 12.3 11.2 12.3 11.1 12.3 10.5 12.1 8.7 11.3 7.7 9.3 7.6 9.3 7.6 9.2 7.7 9.1L8.5 8.2C8.5 8.1 8.6 8 8.5 7.9L7.6 5.8C7.6 5.7 7.5 5.6 7.4 5.6Z"/></g>
                        </svg>
                    </span>
                <span class="off-screen">Rhannu hwn ar WhatsApp</span>
            </a>
        </li>
        <li class="twite__channel-out twite__channel-out--mobile twite__channel-out--messengermobile twite__channel-click-extracted--messengermobile twite__list-elements" aria-hidden="true">
            <a class="extracted__channel-link extracted__channel-link--messengermobile"href='fb-messenger://share?app_id=58567469885&amp;redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890&amp;link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FCMP%3Dshare_btn_me' target=_blank rel=noopener tabindex="-1">
                    <span class="extracted__icon extracted__icon--messengermobile" data-platform="messengermobile">
                    <svg class="extracted-svg ex-messengermobile" viewBox="-14 -13 44 44" enable-background="new 0 0 44 44" width="44px" height="44px" aria-hidden="true" focusable="false">
                    <g><path d="M9.84804801,11.1721834 L7.54389655,8.77893955 L3.1059828,11.2323207 L7.97153994,6.06941781 L10.2756914,8.46377529 L14.7136051,6.00928046 L9.84804801,11.1721834 Z M8.90923715,0 C3.98911093,0 0,3.73074306 0,8.33125039 C0,10.9494525 1.29183939,13.2847862 3.3097816,14.8116068 L3.3097816,18 L6.35117243,16.3139269 C7.16079936,16.5399988 8.02054074,16.6625008 8.90923715,16.6625008 C13.830477,16.6625008 17.8184743,12.9328714 17.8184743,8.33125039 C17.8184743,3.73074306 13.830477,0 8.90923715,0 L8.90923715,0 Z"/></g>
                        </svg>
                    </span>
                <span class="off-screen">Rhannu hwn ar Messenger</span>
            </a>
        </li>
        <li class="twite__channel-out twite__channel-out--mobile twite__channel-out--twitter twite__channel-click-extracted--twitter twite__list-elements" aria-hidden="true">
            <a class="extracted__channel-link extracted__channel-link--twitter"onclick="window.open('https://twitter.com/intent/tweet?text=BBC%20Cymru%20Fyw%20-%20Galw%20am%20broses%20dendro%20wedi%20penderfyniad%20morlyn%20Abertawe&amp;url=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=550,height=250').opener = null" href='#' class=shortenUrl data-social-url=https://twitter.com/intent/tweet?text=BBC+Cymru+Fyw+-+Galw+am+broses+dendro+wedi+penderfyniad+morlyn+Abertawe&amp;amp;url= data-target-url=http://www.bbc.co.uk/cymrufyw/44647890 tabindex="-1">
                    <span class="extracted__icon extracted__icon--twitter" data-platform="twitter">
                    <svg class="extracted-svg ex-twitter" viewBox="-13 -15 44 44" enable-background="new 0 0 44 44" width="44px" height="44px" aria-hidden="true" focusable="false">
                    <g><path d="M5.80573373,15 C12.7721527,15 16.581877,9.22887915 16.581877,4.22385671 C16.581877,4.06002242 16.581877,3.89618812 16.5714931,3.73466135 C17.3122088,3.19816171 17.9525471,2.53359441 18.4602026,1.77326482 C17.7690988,2.08016568 17.0364595,2.28092039 16.28536,2.36976011 C17.0756874,1.89671742 17.6675677,1.15138674 17.9502395,0.274527115 C17.2072164,0.715264453 16.3938137,1.02678037 15.5457981,1.19407596 C14.1105174,-0.331198284 11.7118448,-0.405039095 10.1865706,1.0290879 C9.20241101,1.95440555 8.78590269,3.33315194 9.09049603,4.64844138 C6.04571636,4.4961447 3.20861397,3.05740266 1.28529161,0.691035437 C0.280364327,2.42167943 0.793788713,4.63574999 2.45751448,5.74682343 C1.85525036,5.72951699 1.26567764,5.56683646 0.738408105,5.27262698 L0.738408105,5.32108501 C0.739561868,7.12441605 2.00985456,8.67622684 3.77741896,9.03389326 C3.2201516,9.18618993 2.63519393,9.20811142 2.06754269,9.09850397 C2.56366064,10.6410847 3.98509624,11.6979313 5.60613279,11.7290828 C4.26430681,12.7824682 2.60750362,13.3547344 0.902242404,13.3535807 C0.601110348,13.3524269 0.299978293,13.3339667 7.10542736e-15,13.2982001 C1.73295152,14.4104273 3.74742113,15 5.80573373,14.9965387"/></g>
                        </svg>
                    </span>
                <span class="off-screen">Rhannu hwn ar Twitter</span>
            </a>
        </li>
    <li class="twite twite__list-elements">
        <a href="#share-tools" class="twite__share-button" aria-label="Open share panel" data-origin="page" aria-expanded="false" aria-haspopup="true">
            <svg class="twite__share-icon" aria-hidden="true" focusable="false" viewBox="0 0 29.266 32"><path d="M5.473 22.153c1.586 0 3.01-.684 4.012-1.762l9 4.845c-.102.412-.16.85-.16 1.297 0 3.02 2.452 5.468 5.472 5.468 3.017 0 5.47-2.446 5.47-5.468 0-3.023-2.453-5.47-5.47-5.47-1.587 0-3.02.68-4.015 1.757l-9.457-5.175-.074-2.792 9.74-5.456c.99.953 2.327 1.543 3.807 1.543 3.017 0 5.47-2.45 5.47-5.474 0-3.022-2.453-5.467-5.47-5.467-3.02 0-5.473 2.444-5.473 5.466 0 .554.08 1.09.243 1.597L9.27 12.75c-.988-.95-2.326-1.537-3.797-1.537C2.447 11.213 0 13.657 0 16.68c0 3.03 2.447 5.473 5.473 5.473"/></svg><span class="twite__share-text">Rhannu</span>
        </a>
        <div class="twite__panel arrow-top" data-share-uri="">
            <p class="twite__title" aria-hidden="true">Rhannu hwn ar</p>
            <span class="off-screen">Mae’r rhain yn ddolenni allanol ac yn agor mewn ffenest newydd</span>
            <ul class="twite__channels">
                    <li class="twite__channel twite__channel--email twite__channel-click--email">
                        <a class="twite__channel-link"href='mailto:?subject=Rhannwyd%20o%20wefan%20Cymrufyw%20y%20BBC&amp;body=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890' >
                            <span class="twite__icon twite__icon--email" data-platform="email"></span>
                            <p class="twite__channel-text" aria-hidden="true">Ebost</p>
                            <span class="off-screen">Rhannu hwn ar Ebost</span>
                        </a>
                    </li>
                    <li class="twite__channel twite__channel--facebook twite__channel-click--facebook">
                        <a class="twite__channel-link"onclick="window.open('http://www.facebook.com/dialog/feed?app_id=58567469885&amp;redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fnews%2Fspecial%2Fshared%2Fvj_sharetools%2Ffb_red_uri.html&amp;link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FSThisFB&amp;display=popup', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=555,height=615').opener = null" href='#' >
                            <span class="twite__icon twite__icon--facebook" data-platform="facebook"></span>
                            <p class="twite__channel-text" aria-hidden="true">Facebook</p>
                            <span class="off-screen">Rhannu hwn ar Facebook</span>
                        </a>
                    </li>
                    <li class="twite__channel twite__channel--messengerdesktop twite__channel-click--messengerdesktop">
                        <a class="twite__channel-link"onclick="window.open('http://www.facebook.com/dialog/send?app_id=58567469885&amp;redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fnews%2Fspecial%2Fshared%2Fvj_sharetools%2Ffb_red_uri.html&amp;link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FSThisFB&amp;display=popup', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=645,height=580').opener = null" href='#' >
                            <span class="twite__icon twite__icon--messengerdesktop" data-platform="messengerdesktop"></span>
                            <p class="twite__channel-text" aria-hidden="true">Messenger</p>
                            <span class="off-screen">Rhannu hwn ar Messenger</span>
                        </a>
                    </li>
                    <li class="twite__channel twite__channel--messengermobile twite__channel-click--messengermobile">
                        <a class="twite__channel-link"href='fb-messenger://share?app_id=58567469885&amp;redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890&amp;link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FCMP%3Dshare_btn_me' target=_blank rel=noopener>
                            <span class="twite__icon twite__icon--messengermobile" data-platform="messengermobile"></span>
                            <p class="twite__channel-text" aria-hidden="true">Messenger</p>
                            <span class="off-screen">Rhannu hwn ar Messenger</span>
                        </a>
                    </li>
                    <li class="twite__channel twite__channel--twitter twite__channel-click--twitter">
                        <a class="twite__channel-link"onclick="window.open('https://twitter.com/intent/tweet?text=BBC%20Cymru%20Fyw%20-%20Galw%20am%20broses%20dendro%20wedi%20penderfyniad%20morlyn%20Abertawe&amp;url=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890', '_blank', 'toolbar=no,scrollbars=yes,resizable=no,fullscreen=no,top=50,left=50,width=550,height=250').opener = null" href='#' class=shortenUrl data-social-url=https://twitter.com/intent/tweet?text=BBC+Cymru+Fyw+-+Galw+am+broses+dendro+wedi+penderfyniad+morlyn+Abertawe&amp;amp;url= data-target-url=http://www.bbc.co.uk/cymrufyw/44647890>
                            <span class="twite__icon twite__icon--twitter" data-platform="twitter"></span>
                            <p class="twite__channel-text" aria-hidden="true">Twitter</p>
                            <span class="off-screen">Rhannu hwn ar Twitter</span>
                        </a>
                    </li>
            </ul>
            <p class="twite__copy-text">Copïo’r ddolen yma</p>
            <div class="twite__copy-input">
                <a class="twite__share-link" href="http://www.bbc.co.uk/cymrufyw/44647890" tabindex="-1" contenteditable="true">http://www.bbc.co.uk/cymrufyw/44647890</a>
            </div>
            <a class="twite__read-more" href="cymrufyw/28674343">Ynglŷn â rhannu</a>
            <p class="twite__new-window" aria-hidden="true">Mae’r rhain yn ddolenni allanol ac yn agor mewn ffenest newydd</p>
            <button class="twite__close-button">
                <span class="off-screen">Cau’r blwch rhannu</span>
                <div class="twite__close-button-graphic" aria-hidden="true"></div>
            </button>
        </div>
    </li>
</ul>

        
    </div>

                    </div>
                            </div>
                    </div>
    </div>

    <div class="story-body__inner" property="articleBody">
        <figure class="media-landscape no-caption full-width lead">
            <span class="image-and-copyright-container">
                
                <img class="js-image-replace" alt="Morlyn" src="https://ichef.bbci.co.uk/news/320/cpsprodpb/13443/production/_93551987_hi037230351.jpg" width="976" height="549">
                
                
                
                 <span class="off-screen">Image copyright</span>
                 <span class="story-image-copyright">PA</span>
                
            </span>
            
        </figure><p class="story-body__introduction">Mae datblygwyr sy'n gobeithio cael cefnogaeth Llywodraeth y DU i godi pwerdai ynni llanw yn dweud eu bod am barhau â'u cynlluniau, er gwaethaf penderfyniad i wrthod cynllun arloesol morlyn Bae Abertawe.</p><p>Wedi i'r Ysgrifennydd Ynni a Busnes, Greg Clark ddweud ei fod yn "frwd" ynghylch y dechnoleg pe bai modd rhoi gwerth am arian, mae un cwmni'n galw am sefydlu proses dendro gystadleuol.</p><p>Mae datblygwyr morlyn Abertawe, Tidal Lagoon Power's (TLP) yn ystyried eu camau nesaf <a href="http://www.bbc.co.uk/cymrufyw/44370341" class="story-body__link">wedi i'r cynllun £1.3bn gael ei wrthod</a>. </p><p>Pe byddai wedi cael ei gymeradwyo, fe fyddai wedi profi'r dechnoleg gan arwain at forlynnoedd mwy nerthol, gan gynnwys rhai yng Nghaerdydd, Casnewydd a Bae Colwyn.</p><p>Roedd <a href="http://www.bbc.co.uk/cymrufyw/38597444" class="story-body__link">adolygiad annibynnol wedi argymell codi'r morlyn</a> ond dywedodd Llywodraeth y DU fod y cynllun yn rhy ddrud.</p><p>Mae datblygwyr eraill yn dweud eu bod yn cadw golwg manwl ar y sefyllfa. </p><h2 class="story-body__crosshead">Buddiannau cost-effeithiol</h2><p>Dywedodd Henry Dixon, cadeirydd North Wales Tidal Energy (NWTE) fod penderfyniad y llywodraeth yn un "anghywir" ond na fydd yn atal y cwmni rhag "parhau i ddatblygu a hybu" eu cynlluniau nhw.</p><p>Mae'n dweud y byddai cynllun NWTE i godi lagŵn gwerth £7bn rhwng Llandudno a Thalacre yn Sir Y Fflint yn fwy na chynllun Abertawe, yn cynhyrchu mwy o ynni a refeniw, ac yn fanteisiol o ran atal llifogydd a gwarchod yr arfordir.</p><p>Mae'r cwmni, meddai Mr Dixon, yn croesawu gwahoddiad Mr Clark i drafod gyda'i adran ac i amlygu'r "buddiannau cost-effeithiol niferus... i ogledd Cymru a gweddill y wlad".</p><figure class="media-landscape has-caption full-width">
            <span class="image-and-copyright-container">
                
                
                <div class="js-delayed-image-load" data-alt="Greg Clark" data-src="https://ichef.bbci.co.uk/news/320/cpsprodpb/11935/production/_102198917_p06c2pnv.jpg" data-width="976" data-height="549"></div>
                
                
            </span>
            
            <figcaption class="media-caption">
                <span class="off-screen">Image caption</span>
                <span class="media-caption__text">
                    Dywed Greg Clark ei fod yn 'frwd' ynghylch cyflwyno technolegau adnewyddadwy pan gyrhaeddan nhw lefel 'gystadleuol'
                </span>
            </figcaption>
            
        </figure><p>Yn ôl gwrthwynebydd blaenllaw i gynlluniau TLP, mae gofyn i weinidogion osod amserlen i ddatblygwyr gynnig prosiectau, yn y gobaith y byddai costau'n gostwng o ganlyniad cystadleuaeth.</p><p>Mae Dale Vince - sylfaenydd Ecotricity, un o ddarparwyr ynni adnewyddadwy mwyaf y DU - yn credu y gallen nhw godi morlynnoedd rhatach yn Aber Solway, ar y ffin rhwng Cumbria a'r Alban. Yn wahanol i gynllun TLP, fe fyddai eu lagŵns ymhell o'r lan.</p><p>Dywedodd Mr Vince bod cost cynhyrchu ynni o ffermydd gwynt yn y môr wedi haneru yn y tair blynedd diwethaf wrth i gwmnïau gystadlu am nawdd y llywodraeth trwy'r broses 'Contracts For Difference', ac mae'n galw am gytundebau tebyg yn achos morlynnoedd.  </p><p>Mae'n gobeithio y byddai proses dendro yn arwain at "bris y byddai'r llywodraeth yn fodlon talu am lagŵns, a fyddai'n llawer is na phris Bae Abertawe."</p><h2 class="story-body__crosshead">'Penderfynol'</h2><p>Dywedodd prif weithredwr TLP, Mark Shorrock, fod y cwmni a'u cefnogwyr yn "benderfynol" o wireddu cynllun Bae Abertawe ac yn dechrau edrych ar ffyrdd gwahanol o wneud hynny. </p><p>Yn ôl Shea Buckland-Jones o'r Sefydliad Materion Cymreig, mae "cyfle anferthol" wedi'i golli, a bod angen y cymysgedd ehangaf bosib o ynni adnewyddadwy i ddiwallu anghenion Cymru yn y dyfodol.</p><figure class="media-landscape no-caption full-width">
            <span class="image-and-copyright-container">
                
                
                <div class="js-delayed-image-load" data-alt="Morlyn" data-src="https://ichef.bbci.co.uk/news/320/cpsprodpb/98B6/production/_102249093_mediaitem93361308.jpg" data-width="976" data-height="549"></div>
                
                
                 <span class="off-screen">Image copyright</span>
                 <span class="story-image-copyright">Tidal Lagoon Power</span>
                
            </span>
            
        </figure><p>Eglurdeb gan Lywodraeth y DU sydd angen bellach, medd David Jones, cyfarwyddwr prosiect gyda chynrychiolwyr y sector, Ynni Morol Cymru.</p><p>"Bydd ynni morol yn dilyn esiampl gostyngiad cost ynni gwynt yn y môr, a bydd cwmnïau a chymunedau'n elwa," meddai.</p><p>Dywedodd Mr Clark wrth BBC Cymru y byddai'n parhau i ariannu ymchwil i dechnolegau adnewyddadwy, a'i fod yn barod i wrando ar syniadau da.</p><p>"Mae gyda ni gyfrifoldeb i sicrhau nad ydy biliau defnyddwyr a threthdalwyr yn codi'n ddychrynllyd," meddai.</p><p>"Rydym eisiau cael y technolegau yma i lefel gystadleuol ac rydym yn frwd ynglŷn â'u cyflwyno pan gyrhaeddan nhw'r lefel yna." </p>
            </div>
</div>
                                                                                            <div id="topic-tags"><div id="u9254148690961301"><div class="tags-container"><h2 class="tags-title story-body__crosshead">Pynciau Cysylltiedig</h2><ul class="tags-list"><li class="tags-list__tags" data-entityid="topic_link_bottom"><a href="/cymrufyw/pynciau/ckzwze4mvywt/abertawe">Abertawe</a></li><li class="tags-list__tags" data-entityid="topic_link_bottom"><a href="/cymrufyw/pynciau/c16gy98k977t/busnes">Busnes</a></li><li class="tags-list__tags" data-entityid="topic_link_bottom"><a href="/cymrufyw/pynciau/cndwd1kx0zmt/ynni">Ynni</a></li></ul></div></div></div>
                                                                                                <div class="share share--lightweight  show ghost-column">
            <div id="share-tools"></div>
            <h2 class="share__title share__title--lightweight">
        Rhannu'r stori hon        <a href="http://www.bbc.co.uk/cymrufyw/28674343">Ynglŷn&nbsp;â&nbsp;rhannu</a>
    </h2>
        <ul class="share__tools share__tools--lightweight">
                            <li class="share__tool share__tool--email">
        <a href="mailto:?subject=Rhannwyd%20o%20wefan%20Cymrufyw%20y%20BBC&body=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890" >
            <span>Ebost</span>
        </a>
    </li>
                            <li class="share__tool share__tool--facebook">
        <a href="http://www.facebook.com/dialog/feed?app_id=58567469885&redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890&link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FSThisFB&display=popup" >
            <span>Facebook</span>
        </a>
    </li>
                            <li class="share__tool share__tool--messengerdesktop">
        <a href="http://www.facebook.com/dialog/send?app_id=58567469885&redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890&link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FSThisFB&display=popup" >
            <span>Messenger</span>
        </a>
    </li>
                            <li class="share__tool share__tool--messengermobile">
        <a href="fb-messenger://share?app_id=58567469885&redirect_uri=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890&link=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890%3FCMP%3Dshare_btn_me" target=_blank rel=noopener>
            <span>Messenger</span>
        </a>
    </li>
                            <li class="share__tool share__tool--twitter">
        <a href="https://twitter.com/intent/tweet?text=BBC%20Cymru%20Fyw%20-%20Galw%20am%20broses%20dendro%20wedi%20penderfyniad%20morlyn%20Abertawe&url=http%3A%2F%2Fwww.bbc.co.uk%2Fcymrufyw%2F44647890" class=shortenUrl data-social-url=https://twitter.com/intent/tweet?text=BBC+Cymru+Fyw+-+Galw+am+broses+dendro+wedi+penderfyniad+morlyn+Abertawe&amp;url= data-target-url=http://www.bbc.co.uk/cymrufyw/44647890>
            <span>Twitter</span>
        </a>
    </li>
            </ul>
</div>

                                                                                                <div class="share__back-to-top ghost-column"">
	<a href="#orb-banner">
		<span>Yn ôl i'r brig</span>
	</a>
</div>
                                                                                                <div class="story-more">
          <div class="group story-alsos more-on-this-story"> <div class="group__header"> <h2 class="group__title">Straeon perthnasol</h2> </div> <div class="group__body"> <ul class="units-list ">    <li class="unit unit--regular" data-entityid="more-on-this-story#1" >  <a href="/cymrufyw/44609093" class="unit__link-wrapper"> <div class="unit__body"> <div class="unit__header">  <div class="unit__title">     <span class="cta"> Carwyn Jones: 'Byddai Gogledd Iwerddon wedi cael morlyn' </span> </div>    <div class="unit__meta"> <div class="date date--v1" data-seconds="1530007347" data-datetime="26 Mehefin 2018">26 Mehefin 2018</div> </div>  </div> </div> </a>  </li>     <li class="unit unit--regular" data-entityid="more-on-this-story#2" >  <a href="/cymrufyw/44370341" class="unit__link-wrapper"> <div class="unit__body"> <div class="unit__header">  <div class="unit__title">     <span class="cta"> Llywodraeth y DU yn gwrthod morlyn llanw Bae Abertawe </span> </div>    <div class="unit__meta"> <div class="date date--v1" data-seconds="1529946418" data-datetime="25 Mehefin 2018">25 Mehefin 2018</div> </div>  </div> </div> </a>  </li>   </ul> </div> </div>      </div>
                                                                                            
                                                                                            <div id="comp-small-promo-group" class="small-promo-group"data-comp-meta="{&quot;id&quot;:&quot;comp-more-from-this-index&quot;,&quot;type&quot;:&quot;more-from-this-index&quot;,&quot;handler&quot;:&quot;moreFromThisIndex&quot;,&quot;deviceGroups&quot;:null,&quot;opts&quot;:{&quot;assetId&quot;:&quot;44647890&quot;,&quot;loading_strategy&quot;:&quot;post_load&quot;,&quot;bespoke_post_load_handler&quot;:&quot;module\/components\/moreFromThisIndexAdapter&quot;,&quot;asset_id&quot;:&quot;\/newyddion\/de-orllewin&quot;,&quot;exclude_item&quot;:&quot;44647890&quot;}}">
        <h2 class="group-title ">
            <a href="/newyddion/de-orllewin" class="group-title__link">Mwy o Newyddion</a>
            
        </h2>
    <div class="small-promo-group__body promo-unit-spacer">
    </div>
</div>
                                                                        </div>
                                     <div class="column--secondary">
                                                                                    <div id=comp-top-stories-promo
            class="hidden"
            data-comp-meta="{&quot;id&quot;:&quot;comp-top-stories-promo&quot;,&quot;type&quot;:&quot;top-stories-promo&quot;,&quot;handler&quot;:&quot;default&quot;,&quot;deviceGroups&quot;:[&quot;group3&quot;,&quot;group4&quot;],&quot;opts&quot;:{&quot;assetId&quot;:&quot;44647890&quot;,&quot;loading_strategy&quot;:&quot;post_load&quot;,&quot;device_groups&quot;:[&quot;group3&quot;,&quot;group4&quot;],&quot;dedup_id&quot;:&quot;\/cymrufyw\/44647890&quot;},&quot;template&quot;:&quot;\/component\/top-stories-promo&quot;}">
        </div>                                                                                            <div class="bbccom_slot old-ads" data-comp-meta="{&quot;id&quot;:&quot;comp-adverts-2&quot;,&quot;type&quot;:&quot;adverts&quot;,&quot;handler&quot;:&quot;adverts&quot;,&quot;deviceGroups&quot;:null,&quot;opts&quot;:{&quot;assetId&quot;:&quot;44647890&quot;,&quot;ad_type&quot;:&quot;mpu&quot;},&quot;template&quot;:&quot;\/component\/adverts&quot;}">
    <div class="bbccom_advert bbccom_display_none">
        <script type="text/javascript">
            if (typeof bbcdotcom !== 'undefined' && typeof bbcdotcom.objects !== 'undefined' &&
                    bbcdotcom.objects('bbcdotcom.adverts.slot')) {
                bbcdotcom.adverts.slot('mpu', [1,2,3,4]);
            }
        </script>
    </div>
    <script type="text/javascript">
        if (typeof bbcdotcom !== 'undefined' && typeof bbcdotcom.objects !== 'undefined' &&
                bbcdotcom.objects('bbcdotcom.adverts.slot')) {
            bbcdotcom.adverts.adRegister.getCurrentAd().show();
        }
    </script>
</div>
                                                                                                    <div id=comp-features-and-analysis
            class="hidden"
            data-comp-meta="{&quot;id&quot;:&quot;comp-features-and-analysis&quot;,&quot;type&quot;:&quot;features-and-analysis&quot;,&quot;handler&quot;:&quot;default&quot;,&quot;deviceGroups&quot;:null,&quot;opts&quot;:{&quot;assetId&quot;:&quot;44647890&quot;,&quot;asset_id&quot;:&quot;front_page&quot;,&quot;loading_strategy&quot;:&quot;post_load&quot;,&quot;show_summary&quot;:true,&quot;dedup_id&quot;:&quot;\/cymrufyw\/44647890&quot;}}">
        </div>                                                                        </div>
             </div>          </div> </div>      </div> 
   

<div id="core-navigation" class="navigation--footer">
    <h2 class="navigation--footer__heading">BBC Cymru Fyw Navigation</h2>

    
    <nav id="navigation--bottom" class="navigation navigation--bottom " role="navigation" aria-label="BBC Cymru Fyw">
                    <span class="navigation-core-title">Adrannau</span>
                <ul class="navigation--bottom__toplevel">
                        <li class="">
                    <a href="/cymrufyw" class="">
                        <span>Hafan</span>
                    </a>
                                                        </li>
                            <li class="">
                    <a href="/cymrufyw/cylchgrawn" class="">
                        <span>Cylchgrawn</span>
                    </a>
                                                        </li>
                            <li class="">
                    <a href="/cymrufyw/gwleidyddiaeth" class="">
                        <span>Gwleidyddiaeth</span>
                    </a>
                                                        </li>
                            <li class="">
                    <a href="/cymrufyw/gogledd-orllewin" class="">
                        <span>Gog-Orll</span>
                    </a>
                                                        </li>
                            <li class="">
                    <a href="/cymrufyw/gogledd-ddwyrain" class="">
                        <span>Gog-Ddwy</span>
                    </a>
                                                        </li>
                            <li class="">
                    <a href="/cymrufyw/canolbarth" class="">
                        <span>Canolbarth</span>
                    </a>
                                                        </li>
                            <li class="selected ">
                    <a href="/cymrufyw/de-orllewin" class="navigation-arrow--open">
                        <span>De-Orll</span>
                    </a>
                     <span class="off-screen">selected</span>                                    </li>
                            <li class="">
                    <a href="/cymrufyw/de-ddwyrain" class="">
                        <span>De-Ddwy</span>
                    </a>
                                                        </li>
                            <li class="">
                    <a href="/news/wales" class="">
                        <span>Wales News</span>
                    </a>
                                                        </li>
                    </ul>
    </nav>
</div>   

    <div id="comp-pattern-library-2" class="distinct-component-group ">
        
            <div id="gwasanaethau-bbc-cymru-fyw" class="blue-tit" role="navigation" aria-label="Gwasanaethau BBC Cymru Fyw">
    <div class="blue-tit__inner">
        <h2 class="blue-tit__title">Gwasanaethau BBC Cymru Fyw</h2>
        <ul class="blue-tit__list">
            <li class="blue-tit__list-item">
                <a href="http://www.bbc.co.uk/cymrufyw/34490235" class="blue-tit__list-item-link contact-us">Cysylltwch â ni</a>
            </li>
            <li class="blue-tit__list-item">
                <a href="http://www.bbc.co.uk/cymrufyw/34475910" class="blue-tit__list-item-link mobile">Tabledi a ffonau symudol</a>
            </li>
            <li class="blue-tit__list-item">
                <a href="http://www.bbc.co.uk/cymrufyw/31440562" class="blue-tit__list-item-link connected-tv">Hefyd yn Gymraeg</a>
            </li>
        </ul>
    </div>
</div>

        
    </div>

  </div><!-- closes #site-container -->      </div> <div id="orb-footer"  class="orb-footer orb-footer-grey b-footer--grey--white" >  <aside role="complementary"> <div id="orb-aside" class="orb-nav-sec b-r b-g-p"> <div class="orb-footer-inner" role="navigation"> <h2 class="orb-footer-lead">O amgylch y BBC</h2> <div class="orb-footer-primary-links"> <ul>    <li  class="orb-nav-home orb-d"  > <a href="http://www.bbc.co.uk/">Hafan</a> </li>    <li  class="orb-nav-homedotcom orb-w"  > <a href="http://www.bbc.com/">Hafan</a> </li>    <li  class="orb-nav-news orb-d"  > <a href="http://www.bbc.co.uk/newyddion/">Newyddion</a> </li>    <li  class="orb-nav-newsdotcom orb-w"  > <a href="http://www.bbc.com/news">Newyddion</a> </li>    <li  class="orb-nav-sport"  > <a href="/sport/">Sport</a> </li>    <li  class="orb-nav-weather"  > <a href="/weather/cy/">Tywydd</a> </li>    <li  class="orb-nav-shop orb-w"  > <a href="http://shop.bbc.com/">Shop</a> </li>    <li  class="orb-nav-earthdotcom orb-w"  > <a href="http://www.bbc.com/earth/">Earth</a> </li>    <li  class="orb-nav-travel-dotcom orb-w"  > <a href="http://www.bbc.com/travel/">Travel</a> </li>    <li  class="orb-nav-capital orb-w"  > <a href="http://www.bbc.com/capital/">Capital</a> </li>    <li  class="orb-nav-iplayer orb-d"  > <a href="/iplayer/cy/">iPlayer</a> </li>    <li  class="orb-nav-culture orb-w"  > <a href="http://www.bbc.com/culture/">Culture</a> </li>    <li  class="orb-nav-autos orb-w"  > <a href="http://www.bbc.com/autos/">Autos</a> </li>    <li  class="orb-nav-future orb-w"  > <a href="http://www.bbc.com/future/">Dyfodol</a> </li>    <li  class="orb-nav-tv"  > <a href="/tv/">TV</a> </li>    <li  class="orb-nav-radio"  > <a href="/radio/">Radio</a> </li>    <li  class="orb-nav-cbbc"  > <a href="/cbbc">CBBC</a> </li>    <li  class="orb-nav-cbeebies"  > <a href="/cbeebies">CBeebies</a> </li>    <li  class="orb-nav-food"  > <a href="/food/">Food</a> </li>    <li  > <a href="/iwonder">iWonder</a> </li>    <li  > <a href="/education">Bitesize</a> </li>    <li  class="orb-nav-travel orb-d"  > <a href="/travel/">Teithio</a> </li>    <li  class="orb-nav-music"  > <a href="/music/">Music</a> </li>    <li  class="orb-nav-earth orb-d"  > <a href="http://www.bbc.com/earth/">Earth</a> </li>    <li  class="orb-nav-arts"  > <a href="/arts/">Celfyddydau</a> </li>    <li  class="orb-nav-makeitdigital"  > <a href="/makeitdigital">Make It Digital</a> </li>    <li  > <a href="/taster">Taster</a> </li>    <li  class="orb-nav-nature orb-w"  > <a href="/nature/">Nature</a> </li>    <li  class="orb-nav-local"  > <a href="/local/">Local</a> </li>    <li  class="orb-nav-tomorrowsworld orb-d"  > <a href="/tomorrowsworld">Tomorrow's World</a> </li>    </ul> </div> </div> </div> </aside> <footer role="contentinfo"> <div id="orb-contentinfo" class="orb-nav-sec b-r b-g-p"> <div class="orb-footer-inner"> <ul>        <li  > <a href="/terms/cymru.shtml">Amodau Defnyddio</a> </li>    <li  > <a href="/cymru/gwybodaeth/">Ynglŷn â'r BBC</a> </li>    <li  > <a href="/privacy/cymru.shtml">Preifatrwydd</a> </li>    <li  > <a href="/privacy/cookies/about">Cwcis</a> </li>    <li  > <a href="/accessibility/">Cymorth Hygyrchedd</a> </li>    <li  > <a href="/guidance/">Clo i rieni</a> </li>    <li  > <a href="/contact/">Cysylltu â’r BBC</a> </li>        <li  > <a href="/bbcnewsletter">Get Personalised Newsletters</a> </li>    <li  class=" orb-w"  > <a href="http://advertising.bbcworldwide.com/">Hysbysebwch gyda ni</a> </li>    <li  class=" orb-w"  > <a href="/privacy/cookies/international/">Dewisiadau hysbys</a> </li>    </ul> <small> <span class="orb-hilight">Copyright &copy; 2018 BBC.</span> The BBC is not responsible for the content of external sites. <a href="/help/web/links/" class="orb-hilight">Read about our approach to external linking.</a> </small> </div> </div> </footer> </div>     <!-- BBCDOTCOM bodyLast --><div class="bbccom_display_none"><script type="text/javascript"> /*<![CDATA[*/ if (window.bbcdotcom && bbcdotcom.data && bbcdotcom.data.stats && bbcdotcom.data.stats === 1 && bbcdotcom.utils && window.location.pathname === '/' && window.bbccookies && bbccookies.readPolicy('performance') ) { var wwhpEdition = bbcdotcom.utils.getMetaPropertyContent('wwhp-edition'); var _sf_async_config={}; /** CONFIGURATION START **/ _sf_async_config.uid = 50924; _sf_async_config.domain = "bbc.co.uk"; _sf_async_config.title = "Homepage"+(wwhpEdition !== '' ? ' - '+wwhpEdition : ''); _sf_async_config.sections = "Homepage"+(wwhpEdition !== '' ? ', Homepage - '+wwhpEdition : ''); _sf_async_config.region = wwhpEdition; _sf_async_config.path = "/"+(wwhpEdition !== '' ? '?'+wwhpEdition : ''); /** CONFIGURATION END **/ (function(){ function loadChartbeat() { window._sf_endpt=(new Date()).getTime(); var e = document.createElement("script"); e.setAttribute("language", "javascript"); e.setAttribute("type", "text/javascript"); e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js'); document.body.appendChild(e); } var oldonload = window.onload; window.onload = (typeof window.onload != "function") ? loadChartbeat : function() { oldonload(); loadChartbeat(); }; })(); } /*]]>*/ </script><script type="text/javascript"> /*<![CDATA[*/ (function() { window.bbcdotcom.bodyLast = true; }()); /*]]>*/ </script></div><!-- BBCDOTCOM all code in page -->  <script type="text/javascript" id="orb-js-script" data-assetpath="http://static.bbci.co.uk/frameworks/barlesque/3.22.55/orb/4/" src="http://static.bbci.co.uk/frameworks/barlesque/3.22.55/orb/4/script/orb.min.js"></script>   
    <script type="text/javascript">

        require.config({
            paths: {
                "mybbc/templates": '//mybbc.files.bbci.co.uk/notification-ui/3.8.4/templates',
                "mybbc/notifications": '//mybbc.files.bbci.co.uk/notification-ui/3.8.4/js'
            }
        });

        require(['mybbc/notifications/NotificationsMain', 'idcta/idcta-1'], function (NotificationsMain, idcta) {
            var loadNotifications = function (fig) {
                if (fig.geo.isUK()) {
                    NotificationsMain.run(idcta, '//mybbc.files.bbci.co.uk/notification-ui/3.8.4/');
                }
            };
            var orbFig = window.orb.fig;
            if (typeof orbFig.load === 'function') {
                // Use new async API from Orbit
                orbFig.load(loadNotifications, loadNotifications);
            } else {
                // Use old sync-only API from PAL orbfig project
                loadNotifications(orbFig);
            }
        });
    </script>

 <script type="text/javascript"> if (typeof require !== 'undefined') { require(['istats-1'], function(istats){ istats.track('external', { region: document.getElementsByTagName('body')[0] }); istats.track('download', { region: document.getElementsByTagName('body')[0] }); }); } </script>   <script type="text/javascript">
  if (window.SEARCHBOX.suppress === false && window.SEARCHBOX.locale && /^en-?.*?/.test(window.SEARCHBOX.locale)) {
    require.config({
      paths: {
        "search/searchbox": window.SEARCHBOX.searchboxAppStaticPrefix,
        "disco-layer": "//nav.files.bbci.co.uk/discovery-layer/0.0.1-272.f146f82/app"
      }
    });

    var orbFig = window.orb.fig;

    var loadSearchSuggest = function (fig) {
        if (fig.geo.isUK()) {
            require(['search/searchbox/searchboxDrawer'], function (SearchboxDrawer) {
              SearchboxDrawer.run(window.SEARCHBOX);
            });
        }
    };
    if (typeof orbFig.load === 'function') {
        // Use new async API from Orbit
        // In event of fig failure provide search suggest functionality by default
        orbFig.load(loadSearchSuggest, loadSearchSuggest);
    } else {
        // Use old sync-only API from PAL orbfig project
        loadSearchSuggest(orbFig);
    }

        var loadDiscoveryLayer = function (fig) {
            if (fig.geo.isUK()) {
                require(['disco-layer'], function (discoLayer) {
                  discoLayer.run("//nav.files.bbci.co.uk/discovery-layer/content/", "//nav.files.bbci.co.uk/discovery-layer/0.0.1-272.f146f82/main.css");
                });
            }
        };
        if (typeof orbFig.load === 'function') {
            orbFig.load(loadDiscoveryLayer);
        } else {
            loadDiscoveryLayer(orbFig);
        }
  }
</script>
 <script>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</script>             <script type="text/javascript">require(["istats-1","orb/cookies"],function(t,e){function o(){return"true"===s&&a}function i(){!c&&o()?setTimeout(function(){t.invoke()},"500"):t.invoke()}var n=navigator.userAgent.toLowerCase(),a=!(n.indexOf("msie")>-1)||parseInt(n.split("msie")[1],10)>10,s="true",c=!1,r=window.orb.fig;if(e.isAllowed("s1")){var u=function(e){o()&&e.geo.isUK()&&require(["megavolt-client"],function(e){e&&"function"==typeof e.getMVTIStatsLabels&&e.getMVTIStatsLabels(function(e){t.addLabels(e),c=!0})})};"function"==typeof r.load?r.load(u):u(r);try{if(!require.s.contexts._.config.paths.idcta)return void i();require(["idcta/idcta-1"],function(e){e&&"function"==typeof e.getIStatsLabels&&t.addLabels(e.getIStatsLabels()),i()},function(t){throw t})}catch(t){console&&"function"==typeof console.log&&console.log("an exception occurred while adding idcta labels to istats, invoking istats without them",t),i()}}});</script> </div><!-- closes .direction -->  <script> window.old_onload = window.onload; window.onload = function() { if(window.old_onload) { window.old_onload(); } window.loaded = true; }; </script> <!-- Chartbeat Web Analytics code - start -->
<script type="text/javascript">
    /** CONFIGURATION START **/
    var _sf_async_config = {};
    
    _sf_async_config.uid = "50924";
    _sf_async_config.domain = "cymrufyw.bbc.co.uk";
    _sf_async_config.sections = "Cymrufyw, Cymrufyw - de-orllewin, Cymrufyw - STY, Cymrufyw - de-orllewin - STY, Cymrufyw - news-category";
    <!-- if page is an index, add the edition to the path -->
    _sf_async_config.path = "bbc.co.uk/cymrufyw/44647890";
    
        (function() {
        var noCookies = true;
        var cookiePrefix = '_chartbeat';
        if ("object" === typeof bbccookies && typeof bbccookies.readPolicy == 'function') {
            noCookies = !bbccookies.readPolicy().performance;
        }
        if (noCookies && document.cookie.indexOf(cookiePrefix) !== -1) {
            //Find and remove cookies whose names begin with '_chartbeat'
            var cookieSplit = document.cookie.split(';');
            var cookieLength = cookieSplit.length;
            while (cookieLength--) {
                var cookie = cookieSplit[cookieLength].replace(/^\s+|\s+$/g, '');
                var cookieName = cookie.split('=')[0];

                if (cookieName.indexOf(cookiePrefix) === 0) {
                    document.cookie = cookieName + '=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/;';
                }
            }
        }
        _sf_async_config.noCookies = noCookies;
    }());

    (function() {
        var cookiePrefix = 'ckpf_sylphid';
        _sf_async_config.idSync = _sf_async_config.idSync || {};

        if (
            "object" === typeof bbccookies &&
            typeof bbccookies.readPolicy == 'function' &&
            bbccookies.readPolicy().performance &&
            document.cookie.indexOf(cookiePrefix) !== -1
        ) {
            var cookieSplit = document.cookie.split(';');
            var cookieLength = cookieSplit.length;
            while (cookieLength--) {
                var cookie = cookieSplit[cookieLength].replace(/^\s+|\s+$/g, '');
                var cookieName = cookie.split('=')[0];
                if (cookieName.indexOf(cookiePrefix) === 0) {
                    _sf_async_config.idSync.bbc_hid = cookieSplit[cookieLength].split('=')[1];
                    break;
                }
            }
        }
    }());

    /** CONFIGURATION END **/
    (function(){
        function loadChartbeat() {
            window._sf_endpt=(new Date()).getTime();
            var e = document.createElement("script");
            e.setAttribute("language", "javascript");
            e.setAttribute("type", "text/javascript");
            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
            document.body.appendChild(e);
        }
        var oldonload = window.onload;
        window.onload = (typeof window.onload != "function") ?
            loadChartbeat : function() { oldonload(); loadChartbeat(); };
    }());
</script>
<!-- Chartbeat Web Analytics code - end -->
      </body> </html> 











